I recently stumbled upon this blog on " Using IIRF URL Rewriting on IIS6 with WordPress" ( http://john-sheehan.com/blog/using-iirf-url-rewriting-on-iis6-with-wordpress/ ) by John Sheehan as I installed a WordPress site I developed on my Mac OS X running MAMP and then ported the site to a MS IIS6 Windows 2003 Server environment.

Going to the home page all works fine but then all my other pages could not be found - 404. My site is setup with PermaLinks in WordPress 3.0.1 where I am using the Custom Structure /http:/www.mysite.com/%postname%/

So an example permalink for one of my pages that cannot be found is http://www.mysite.com/aboutus

Reading up on this, I am assuming the reason my pages cannot be found is because of my .htaccess file not being compatible on IIS 6 server as this is an Apache only file.

Anyways, to cut a long story short, looking at the site/blog entry above, regarding the use of IIRF URL Rewrite and me being a complete newb to rewriting URLs, I have the following queries:

A) To achieve my Permalink Custom Structure of /http:/www.mysite.com/%postname%/ what would my Rule's File look like, so that WordPress on IIS 6 will actually find my pages described above?

B) What is the name of this file and where (location) on the Web Server do I place the Rule file?

C) Do I need to remove my current .htaccess file within my WordPress directory that holds my site on IIS 6?

Any help on this would be much appreciated.


3 Answers 3


Documentation on Using Permalinks suggest this post for setting them up on IIS 6.

  • Hi Rarst. Are you referring to the sub-section "Permalinks without mod_rewrite" in the "Using Permalinks" doc - if so, it seems to specify IIS 7 - would the same apply for IIS 6 ?
    – tonyf
    Commented Sep 27, 2010 at 5:43
  • Nope, closer to start there is Microsoft IIS 6+ using ASAPI_Rewrite line that links to second link in my answer.
    – Rarst
    Commented Sep 27, 2010 at 5:58

No need to install any ISAPI filter to remove the index.php from WordPress permalinks.No need of .htaccess file..Use these simple steps to WordPress Permalinks in IIS 6.0 using Custom 404 Redirect for Windows Shared hosting/manas hosting or any windows shared hosting.



We recently had the same problem. Adding index.php to the start of your custom permalink settings should solve this.

Ours looks like /index.php/%year%/%monthnum%/%category%/%postname%/ and works perfectly for all our posts and pages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.