I recently moved my site to https, by installing a SSL-certificate on the server and updating the site address and site home in the wp-admin to use https.

Due to some errors my client is experiencing with https, I would like to switch back. I have edited the values in the wp-admin, to be without https. I have also followed several options described in: https://codex.wordpress.org/Changing_The_Site_URL

However, nothing seems to work. I am not sure what is going wrong. It seems that internally Wordpress is redirecting all url's to https, although the site_url is changed.

I have also cleared my .htaccess file, but this also does not seem to be the problem. Any help much appreciated.

  • without knowing what exactly is your setup this is too localized to be answered. Apr 19, 2016 at 9:35
  • Why not fix the issues with HTTPS instead? HTTPS is all good.
    – cybmeta
    Apr 19, 2016 at 9:50
  • Could it just be a caching issue at your end? Have you tried elsewhere on other networks to see if the issue happens everywhere? And yes, like @cybmeta I'd suggest it's worth fixing the 'errors' and persisting with https if you can. Apr 19, 2016 at 10:29
  • 1
    You don't have FORCE_SSL_LOGIN or FORCE_SSL_ADMIN defined in wp-config do you? or e.g. a plugin that'll do that for you? You can test if it's your server by doing curl -D - yoursite.com to see the redirect. AFAIK a redirect generated by WordPress will have no HTML body whereas one generated by Apache will.
    – Rup
    Apr 19, 2016 at 12:45
  • 1
    You are right, fixing HTTPS would be great. However, my client is working with some kind of software, that gathers images from their website. HTTPS has broken this software, of which I have no further control. I did not have FORCE_SSL_LOGIN or FORCE_SSL_ADMIN in my wp-config. I also tested over other networks, so it didn't seem like a caching issue. When I do curl -D - www.wscvlietland.nl I now get the version without https. So it seems that by some miracle this issue has resolved itself. Thanks for your pointers though. Apr 19, 2016 at 13:33

1 Answer 1


You can try these:

1. make sure the values changed in database

If you can't login to wp-admin > settings to confirm that, you can go to database, wp_options table and look for siteurl and home values

2. add code to wp-config.php

Add these lines to wp-config.php


3. Clear your cache

Make sure that you clear the cache from any cache plugins you're using and also from your browser

Also try adding this to wp-config.php (note "false")

define( 'WP_CACHE', false );

4. check https / ssl related plugins

You might be using any plugin which is causing this, like ssl insecure content fixer, etc.

5. Cloudflare or other dns side redirect

Make sure that the site isn't using any dns based redirect

6. disable all plugins and confirm

7. change theme to default and check

  • 3
    Thanks, tried all these steps earlier and apparently one of them worked. It appeared that there is some sort of cache on the Wordpress get_option table. I tried to circumvent it in the code, with no result. But apparently this cache is refreshed now, as the domain is working correctly. Apr 20, 2016 at 10:11
  • 1
    I'm glad that it helped. Please mark the answer as correct if it was :) Apr 20, 2016 at 10:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.