4

I'm a pretty basic WordPress user and know enough to install a theme and customize it. I'm helping a friend out with a new website and installed WordPress 4.4.2 in the root directory via cPanel on his uncle's server. This is the first time I've used something other than a host-provided interface. My limited experience has been mainly with GoDaddy where you click a button to install WordPress and...poof...everything works. So perhaps I didn't choose the right options when setting it up?

All the URL's include index.php for some reason. example.com/index.php/contact, example.com/index.php/about, etc.

I've Googled around for solutions and tried messing with the .htaccess file, but nothing has helped. Any ideas?

Let me know if I've omitted any pertinent information that will help shed some light!

Thanks so much,

Kristin

  • What is in the Site Address setting option? Settings > General – Mike Apr 17 '16 at 23:28
  • 2
    Also check Settings > Permalinks. Even if they appear correct, click Save Changes – Mike Apr 17 '16 at 23:34
  • 2
    Mike! You rock! I just needed to edit the permalink structure. All good now. Thanks SOOOO much. – Kristin Apr 18 '16 at 3:49
1

This is usually a permalink issue.

Go to your Wordpress dashboard then look for Settings>Permalinks.

There will be radial selectable options. You can select any that have no mention of index.php.

Alternative select Custom Structure then in the field to the right insert /%monthnum%/%day%/%year%/%postname%/ then save with the button at the bottom of the page.

I know something like this was in the comments but I wanted to make it clear as possible for beginners.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.