0

what I did:

  • I installed Wordpress on XAMPP
  • Build a correctly working theme for Wordpress
  • Copied this theme to another folder next to the first one in my Wordpress Themes-folder
  • Made some css Changes and Changed some Header and Footer Tags
  • When I now enable this newly created theme via WP-Admin panel and then try to access the initial page, I get an error that a connection to the server was not possible
  • I found that the Apache has some problems when I try to load this second theme

  • Anybody an idea why Apache behaves like this and how to fix this?
    If any further info is need please just ask me.

    EDIT 1: Thanks for answering Mark, unfortunately I already did look in the serverlogs. The serverlog shows that "Parent: child process exited with status 3221225725 -- Restarting." Google shows this error leads to a stack overflow connected to Windows machines. I then also added to the httpd.conf so that the maximum stack size was actully close to unreachable. Still I'm getting the same error.

    Additionally, if I switch back to the first theme all the problems disappear.

    I also tried a new installation of WordPress with this faulty theme and got the same problems. I'm going to check the debug log whether I find any hints there.

    EDIT 2: So now I set up WP_DEBUG and WP_DEBUG_LOG, unfortunately that doesn't help. The debug logfile in wp-content stays empty. No errors, warnings or notes. Seems like it is indeed an Apache / XAMPP problem. Going to dig in there a little deeper.

    EDIT 3: Eureka! I got close to the error. Seems like I messed up something in my functions.php.
    /*
     * Load Scripts
     */ 
    function wpbootstrap_scripts_with_jquery()
    {
        // Register the script like this for a theme:
        wp_register_script( 'customdrink', get_template_directory_uri() . '/js/customdrink.js', array( 'jquery','jquery-ui-slider' ) );
      wp_register_script( 'jquery-ui-10', get_template_directory_uri() . '/js/jquery-ui-1.10.4.custom.min.js', array( 'jquery' ) );
      wp_register_script( 'bootstrap', get_template_directory_uri() . '/js/bootstrap.js', array( 'jquery' ) );
      wp_register_script( 'awesome-landing-page', get_template_directory_uri() . '/js/awesome-landing-page.js', array( 'jquery', 'jquery-ui-10', 'boostrap' ) );
      // For either a plugin or a theme, you can then enqueue the script:
      wp_enqueue_script( 'customdrink' );
      wp_enqueue_script( 'jquery-ui-1.10' );
      wp_enqueue_script( 'bootstrap' );
      wp_enqueue_scripts( 'awesome-landing-page' );
    }
    add_action( 'wp_enqueue_scripts', 'wpbootstrap_scripts_with_jquery' );

    I'm little unsure where I did go wrong here. Anybody an idea?

    • you will have to ask the xamp maintainers, but yo should look also at the server error log. Nothing that you do in php should bring down the web server – Mark Kaplun Apr 16 '16 at 16:40
    • I added my answer to your comment to my original post. Thanks for taking your time. – TalkToJan Apr 16 '16 at 23:14
    0

    When developing a theme, you should turn on WP_DEBUG in wp-config.php. It will tell you what the error is.

    For your case, it seems a syntax problem which leads to server down, not an apache issue.

    • Going to try this asap. Hopefully this helps me find useful information. Thanks so far. – TalkToJan Apr 16 '16 at 23:15
    • It will be ` define( 'WP_DEBUG', true );` – Tung Du Apr 17 '16 at 0:55
    • Thanks Tung Du , I also added the WP_DEBUG_LOG. Still this doesn't show anything. Added my response to my original post (EDIT 2). Thanks again for answering. – TalkToJan Apr 17 '16 at 10:16
    0

    So after a long search I found my mistake.
    In the functions.php

    wp_enqueue_scripts( 'awesome-landing-page' );
    
    Should be
    wp_enqueue_script( 'awesome-landing-page' );
    
    Without the 's'.
    Seems like a beginners mistake, so sorry for bothering.
    Still I find the misbehaviour of the Apache misleading.
    Bye for now!

    • This should have resulted in php error and (probably) a blank page. You should probably check your error handling settings, maybe somewhere you tell xampp/php to totally bail out on errors. – Mark Kaplun Apr 17 '16 at 11:33
    • Thanks @MarkKaplun , going to take this into account for the next time! – TalkToJan Apr 20 '16 at 10:11

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.