1

My site is http://exteriorinteriorsdesign.com/

After Updating wordpress 4.5,it couldn't load my images and articles on Homepage, and dashboard also doesn't show when i move my cursor over there.

Any solution?

  • Everything is visible on your front page. – Max Yudin Apr 15 '16 at 10:49
8

You are using a theme or plugin that uses a jQuery-dependent script with poor syntax. In this screenshot below of the browser console of the page you referenced, the expression should be ... li > a[href*='#']. Note the missing quotes around the #.

Console screenshot of your site

The bug didn't show up until now because WordPress 4.5 updated the version of jQuery it uses. The new jQuery version doesn't tolerate the bug. Ideally, your plugin/theme provider should issue a fix.

Until then, you can get the old version of jQuery back by adding the following to your theme's functions.php file:

function wpse_use_previous_jquery() {
    if ( ! is_admin() ) {
        wp_deregister_script( 'jquery' );
        wp_register_script( 'jquery', 'https://code.jquery.com/jquery-1.11.3.min.js' );
        wp_enqueue_script( 'jquery' );
    }
}
add_action( 'init', 'wpse_use_previous_jquery' );
| improve this answer | |
  • Thank you for the code snippet. I was starting to get an eye headache. – Ray Mitchell Apr 21 '16 at 18:12
0

It's likely that it's a PHP error related to your template or a plugin, but you'll need more info to solve it. First try disable all plugins and see if that makes a difference.

In order to see any errors that may be occurring, set your PHP display_errors directive to On if you have access, or you can try set the Debug constant in your Wordpress wp-config.php file to true. IE. define( 'WP_DEBUG', true );

If it is a PHP error, the instructions above will help you get more info on what the error is and where it's occurring.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.