0

The latest posts and options are not appearing after importing the database. I'm missing all the latest posts and the latest Advanced Custom Fields.

The export is from the remote server and import to my localhost – using phpMyAdmin on both ends. The database is quite big, 50MB unzipped, but it's under 8MG bzipped, which is how I'm handling it, so I don't think that's the problem.

There are no error messages, and I get a success message after import. Nothing on the sites breaks or shows in Debug. I've tried a number of time.

I have exported and imported Wordpress databases hundreds of times in the past and have no idea why I'm experiencing this problem.

Any ideas? Thanks in advance

  • General troubleshooting: 1) Verify that the missing posts are actually getting exported - find them in your dump file. 2) Import into a clean database. 3) A partial import can succeed without errors - bump up your webserver and PHP upload limits and PHP's script execution timeouts, and uncheck PMA's "Partial Import" option. 4) Even better, try importing from the MySQL command line. 5) Run a serialization-aware search & replace on the imported DB to change all instances of the remote address to your local machine – bosco Apr 13 '16 at 20:19
  • Thanks @bosco 1) The missing posts are in the dump file. 2) Importing into a clean database I find that only 'comments-meta' and 'comments' are being imported. 3) Not sure how to carry out these steps. 4) I'd love to. How? 5) Yep, will do. – Laurence Lord Apr 14 '16 at 8:46
  • thanks @tazotodua but it turns out that's the answer to this one. – Laurence Lord Apr 25 '16 at 13:13
  • I'd been ticking "Add CREATE DATABASE / USE statement" in phpMyAdmin. I tried it without checking this box and it's worked fine. – Laurence Lord Apr 25 '16 at 13:14
0

I reviewed Wordpress' advice on phpMyAdmin and it seems I was adding one extra step which was causing the problem – ticking Add CREATE DATABASE / USE statement.

Exporting without checking this box and results in SQL that imports without any problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.