I cannot upload the .webm video format on WordPress. This is after adding: AddType video/webm .webm

into both: my .htaccess file (on the root folder of the WordPress installation) the mime type handler of our apache server (via our site cpanel)

As far as i remember, at first this message instantly gave me the error, it would even begin uploading it. Now it uploads it all the way and then while crunching, i get the error.

The error is

“1.webm” has failed to upload due to an error
File type does not meet security guidelines. Try another.

Has anyone else had this problem?!

What's really peculiar is that another video format called ogv (Theora) was not being recognised in the html5 player, BUT it wasn't breaching security according to WordPress. So I added the mimetype to the apache (not via htaccess) and voila, it worked.

Also, the file actually 'Uploads', it 'Crunches' and then rejects the file, which is odd, surely WordPress would deduce it can't upload the file format by just checking which file format it is first?


2 Answers 2


On a multisite install, go to the Network Admin area and add the webm file extension to the allowed extensions list.

On a single-site install, add this to your wp-config.php file:


That will allow administrator level users to upload files without the file type restrictions.

The underlying problem is that webm hasn't been added to the filetypes list that WP knows about.


Are you using MU? Because I was having a similar problem; and it solved when I added the extension to the Super Admin > Options > Upload file types.

Curiously, that option seems to me that it doesn't appear in a normal installation, so I don't know where to look for it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.