-2

I'm following a tutorial which is using WP 4.0 and _'s. I'm getting the following error and I don't know why.

Fatal error: Call to undefined function the_posts_navigation()

2

The function the_posts_navigation() was added in WordPress 4.1.0, and will therefore not be available in version 4.0 (which you're using). It's highly advised to keep up to date with the latest version of WordPress anyway for security reasons, so you'd be better off updating to the latest WordPress version.

  • That cannot be stressed enough. WordPress should always be upgraded very shortly after a release. – Cedon Mar 17 '17 at 0:53
1

The the_posts_navigation() is only available from version 4.1 and above

0

I've also followed a tutorial using WordPress 4.0 by Brad Hussy and had the same error message:

Fatal error: Call to undefined function the_posts_navigation() in C:\xampp\htdocs\wordpress\wp-content\themes\bootstrap2wordpress\index.php on line 43

Then I updated WordPress to the latest version and the problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.