1

I've moved a Wordpress site from one domain to another. I have changed the siteurl and home options in the wp-options table, added this tags into wp-login.php file:

update_option('siteurl', 'http://my.new.domain' ); update_option('home', 'http://my.new.domain' );

and I've tried to rewrite the URL using these tags in the wp-config.php file:

define('WP_HOME','http://my.new.domain');
define('WP_SITEURL','http://my.new.domain');

When I enter http://my.new.domain to the address bar, I'm redirected to my old domain. But http://my.new.domain/wp-admin is normally accessible. In the settings I can even see the WordPress Address (URL) and Site Address (URL) with the correct values.

Is there any way to fix this? I have tried (as described above) everything I have found on the web and I am beginning to feel very hopeless.

(Sorry for my English mistakes.)

1
  • 6
    It may be the old browser cache! Try with private browsing or by adding query string http://my.new.domain/?random_string
    – Sumit
    Commented Mar 28, 2016 at 12:49

1 Answer 1

5

As Sumit pointed out, the problem was in the old browser cache. The solution was to clear browser cache (or just add a query string after the address: http://my.new.domain/?random_string).

Thank you.

1
  • Or use incognito mode
    – warunanc
    Commented Aug 11, 2017 at 20:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.