I'm getting this when saving a post after editing:


You don't have permission to access /wp-admin/post.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

All file permissions are 644 and directory permission are 755 and owner is myftpuser:myftpuser (this is my FTP user login). I've tried changing all permission to 755 but didn't work.

Has anyone had this issue, is there a solution?


Sometimes hosting providers will implement mod_security (and not mention anything). Or else, mod_security was already on but a recent installation of a plugin or theme may have exposed this new problem for you.

You can try these four things...

  1. Add the following to your .htaccess file (add to .htaccess, don't replace the other stuff already in it)

    <IfModule mod_security.c>
        SecFilterEngine Off
        SecFilterScanPOST Off
  2. chmod all your folders (including plugin and theme folders) to 777 temporarily just to confirm that it's really not a permissions issue with file owner permissions. If it is, then you can go from there (maybe your site isn't really running as 'myftpuser'.

  3. Deactivate your plugins, one by one, testing your post after deactivating each one. (See if a plugin is causing this).

  4. Does the content you're testing have the word "from" in it? If so, can you post without using that word as a test?

  • I tried 1. to 4. still no success. When I changed all to 777 I got a different server error, so changed back to 755 / 644 and the same as before. I tried putting the .htaccess file in the root dir, no success, and in the wp-admin dir, nothing. I will start from a new wp installation. – tim Jul 6 '11 at 13:51
  • In the end I went for a clean install which worked. I appreciate your answer and believe it will be useful to other WordPress soldiers. – tim Jul 7 '11 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.