I am following this guide.


Step 1 Create the subdirectory for the new WordPress installation with your File Transfer Protocol program.

Step 2 Log in to your WordPress website with the administrator username and password.

Step 3 Click "General" on the dashboard on the left side of the screen. Change the address to the new directory in the "WordPress address (URL)" box. For example, if you want to have WordPress run in the subdirectory "blog," type "http://yourdomain.com/blog." Keep the Site Address (URL) field the same. Click "Save Changes."

Step 4 Copy the WordPress files to the new subdirectory location.

Step 5 Copy the "index.php" and ".htaccess" files from the new subdirectory into the root directory.

Step 6 Open the "index.php" file in the root directory with a text editor. Look for the line that says: require('./wp-blog-header.php'); Replace that line with this line: require('./blog/wp-blog-header.php'); Replace "blog" with the name of your new subdirectory.

Step 7 Open your Web browser to the following address: "http://yourwebsite.com/blog/wp-admin," where "blog" is the title of your new subdirectory.

On step 3, it tells me to change what wordpress considers the root (i.e. settings > general > WordPress Address (URL). But these fields are greyed out and uneditable for me.


1 Answer 1


Your link does not work, but I think it relates to this:

In wp-config.php add these lines before 'Happy Bloggin' text


The documentation here

  • That did it. Looks like that's where those two fields are set. Thanks a bunch. It's strange that they were and still are greyed out.
    – ahnbizcad
    Mar 18, 2016 at 21:17
  • that's probably because it's explicitly set. removing that code probably allows it to be set in the dashboard cms
    – ahnbizcad
    Mar 18, 2016 at 23:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.