2

Just finished moving my local Wordpress install to a live server. Imported my DB, and uploaded my core files to the new server. I also changed the siteurl and home fields in the wp_options table and added the new credentials to the new wp_config file.

Basically followed all the directions here.

The issue is my links are not working. They're redirecting I assume to the parent Wordpress index install.

Heres the file structure of my server

-public_html (I have 4 add-on domains here)
----merchantsofdesign.ca (also a wordpress install)
--------clients
------------creditassur
----------------wordpress (core files are here)

Can I even have a parent folder and child folder both running Wordpress?

Thanks and hope that makes sense

2 Answers 2

6

Go to settings » permalinks and save changes again.

2
  • This worked great, thank you!
    – saman0suke
    Commented Nov 12, 2019 at 2:58
  • Lifesaver.......
    – stigzler
    Commented Feb 26, 2021 at 16:27
0

I also faced this issue I just fixed it by creating new .htaccess file

 # BEGIN WordPress

RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.