0

When pressing the "add media"-button on the edit post page, it opens and the loader keeps spinning without it displaying any images.

The images shows up just fine in the media library tab of the control panel.

Things I've tried so far:

  • Changing theme to TwentySixteen (this works)
  • Disabling all plugins (currently have none installed)
  • Tried running the theme one a different install (does not work, same issue)
  • Empty out the functions.php file (no difference, also note that all javascripts are enqueued and registered from functions.php)
  • Replace all the WordPress files in the environment

So I've kind of narrowed it down to it being a theme-issue. I just can't figure out which part of the theme that might affect the behavior of the "add media" function in WordPress.

Anyone have suggestions to as which files in the theme might affect control panel behavior?

  • Did you check the console for any js errors in browser? Also, if you could enable Debug log and see if there are any errors in log, while you are trying to add media. codex.wordpress.org/… – sven Mar 16 '16 at 9:25
  • That's what threw me off. No error in console, debug file or error log. At least not related. Did however find the cause, malformed functions.php. See my answer for more in depth explanation. Thanks for your suggestions. – sankorati Mar 16 '16 at 17:19
0

After switching workstation the issue became more obvious. When trying to log in, WordPress returned a blank login page. As I didn't get this symptom on the previous workstation as I was logged in, I didn't see the solution.

The blank login page was related to malformed function.php with blank spaces at the beginning of file. Cleared excess spaces/ breaks from beginning of functions.php

Solved following issues: Blank loginpage, blank "add media" dialog and no redirect on saving options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.