-2

I'm running development environment xampp (windows) and production server.

On the DEV virtual machine, everything works correctly, PROD server doesn't work:

  • wp-all-import plugin
  • large XML feed http://www.zoot.cz/exports/affiliate.xml (175 MB)
  • login to wp wp-all-import -> new import -> from URL
  • file correctly downloaded to server -> AJAX redirect to "xpath builder" -> xpath "/PRODUCT" AJAX returns only 15 results
  • no NOTICE/WARNING/ERROR in php log

  • DEV machine imports all 82600 records correctly

I tried to find php config differences, but memory limit, script exec time etc. are the same...

dev machine is PHP 5.4, production PHP 5.3 (but newer version of libxml than in dev)...

Any idea, what could possibly cause the problem?

Thanks

closed as off-topic by Mark Kaplun, Howdy_McGee, Pieter Goosen, birgire, Sisir Apr 1 '16 at 19:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Mark Kaplun, Howdy_McGee, Pieter Goosen, birgire, Sisir
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    so how is this a wordpress specific problem? you are not even using the same PHP versions and who knows what are the other differences. – Mark Kaplun Mar 6 '16 at 3:02
  • you are right... after long 2 days (because wp-all-import plugin uses libxml_use_internal_errors(true)), I've found out, it is encoding issue (source xml file, claims it's utf8, but contains some invalid bytes sequences)... due to the libxml errors turned off, no record in php log was found... for some reason, windows was able to cope with this... – tomas Mar 6 '16 at 23:57
0

wrong source file encoding (not utf8 as xml prolog claims), wp-all-import wordpress plugin hid the php error

Not the answer you're looking for? Browse other questions tagged or ask your own question.