2

I've been looking for a solution to my problem for a while now.

Under my wp_options page I have the following serialized entry saved:

a:17:{s:11:"date_format";s:5:"d/m/Y";s:15:"currency_symbol";s:1:"$";s:14:"recaptcha_lang";s:2:"en";s:13:"req_div_label";s:0:"";s:16:"req_field_symbol";s:1:"*";s:15:"req_error_label";s:81:"Por favor, certifique-se de que todos os campos obrigatórios estão preenchidos.";s:15:"req_field_error";s:29:"Este é um campo obrigatório";s:10:"spam_error";s:53:"Por favor responda a pergunta anti-spam corretamente.";s:14:"honeypot_error";s:41:"Por favor, deixar o campo spam em branco.";s:18:"timed_submit_error";s:47:"Por favor, aguarde a submissão do formulário.";s:16:"javascript_error";s:75:"Você não pode submeter o formulário sem que o Javascript esteja ativado.";s:13:"invalid_email";s:50:"Por favor entre com um endereço de email válido.";s:13:"process_label";s:11:"Processando";s:17:"password_mismatch";s:35:"As senhas informadas não conferem.";s:18:"fix_field_reply_to";i:1;s:19:"fix_form_email_from";i:1;s:7:"version";s:6:"2.9.33";}

Note that I have some latin characters in there such as "Este é um campo obrigatório". When displaying this specific string in the front end I get the following result: "Este é um campo obrigatório"

Other latin characters saved in the same table are displaying just fine, the bloginfo('description') for example. The mentioned string comes from a Ninja Form option.

I`ve tried changing my wp-config.php charset, the header meta charset, the database collation and the table charset but nothing seems to work.

I`m not sure if that might help but I had some problems with email that were sent through wp_mail displaying the same odd characters instead of the proper latin ones.

Any help here is appreciated! Thank you very much.

  • Can you check the charset in the HTTP Content-type header of the response (not the head meta charset)? – cybmeta Mar 4 '16 at 14:51
  • Hello @cybmeta thank you for your response. Here is the response header you mentioned (I believe): HTTP/1.1 200 OK Date: Fri, 04 Mar 2016 20:47:57 GMT Content-Length: 545 Content-Type: text/html – Vitor Argos Mar 4 '16 at 20:51
  • 1
    I think It should be Content-Type: text/html; charset=utf-8. I think it is better if you contact with your hosting provider. – cybmeta Mar 5 '16 at 7:34
  • I really appreciate your input @cybmeta I was able to set the content-type charset to UTF-8 by editing my htaccess file but that didn't solve the problem. I've noticed that if Ajax is disabled the error messages are displayed just fine. I've contacted Ninja Forms support for more details on this issue but still, any assistance here would be appreciated as I believe they will simply tell me that that's not an issue with their plugin. I tried to disable all other plugins as well with no luck. – Vitor Argos Mar 6 '16 at 17:57
0

I`ve resolved this issue by enabling a newer version of PHP in my htaccess:

AddHandler application/x-httpd-php55 .php

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.