0

we are using Wordpress 4.4.2 and the Wordpress Media Library for media management. We have noticed that as media (images, not videos or audio) number increases, the upload process takes too long...and the time it takes is about the same for both ie 50 kB and 6 MB images! It is not a network problem, this has been verified. Does Wordpress Media Library use an indexing method that slows the process down when the image number is big? Can we change the media upload directory so as to have an empty one at intervals?

Thank you in advance

  • Well when you upload image usually thumbnails are being created. Could it be that you have configured many custom image sizes? – denis.stoyanov Mar 3 '16 at 10:10
  • Hi, thank you for our comment. We have set 150x150 size for that at Settings->Media (and have checked the option below: Crop thumbnail to exact dimensions). Does it have an effect? – theoniza Mar 3 '16 at 13:16
1

To anyone who faces the same issue, the problem was caused by WP Smush. Once we deactivated it, images were uploaded within seconds. We use nginx and gzip is doing the necessary compression anyway.

Kind Regards

|improve this answer|||||
  • 1
    Or you could just uncheck the option "Smush images on upload" and the plugin won't interfere at all in the uploading process and you still get to optimise your images using the Bulk Smush or Manually in Media Library – Kumar Mar 30 '16 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.