0

I would like to use Auto Update feature to update wordpress. I see this question was asked 5 years ago I would prefer doing the upgrade using Automatic update instead of manual process and fix what's broken or the cause in my environment

My Environment

  • FTP is enabled
  • I am able to install themese using the same ftp account
  • Permissions on website directory drwxr-xr-x

Sequence of steps

when i hit Update now and then type ftp password and hit proceed

Downloading update from https://downloads.wordpress.org/release/wordpress-4.4.2-partial-1.zip

Unpacking the update…

Verifying the unpacked files…

The update could not be unpacked

Installation Failed

What i have tried

  • Change permissions to 777
  • Found this on wordpress.org "one-click updates without entering FTP credentials" so my website does ask for FTP credentials, not sure how to make it one-click
  • I had a similar problem. Wordpress upgrade failed with an unpacking issue. It was a Vsftpd 3.0.2 bug in fact on Debian. Now I use unstable 3.0.3 and it works perfectly. Reference: insanepengu.in/… – wawash Feb 3 '17 at 10:32
0

I had to change the ownership of the directory

Current Ownership was username:www-data

Changed it to www=data:www-data

after this it's not asking for my ftp password anymore and update is working with just one click

Reference

https://wordpress.org/support/topic/plugin-install-asks-for-ftp-details

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.