0

I'm successfully able to login but the links point to 404s until I correct them manually. Here's the step by step scenario:

  1. Visited wp-admin/wp-login.php and login successfully say the dashboard link is localhost
  2. When hovered over other links on the sidebar they don't have 'wp-admin' in them. For eg., it says localhost/edit.php instead of locahost/wp-admin/edit.php. When I correct it manually in the URL bar, it works but that's not how it's supposed to be.
  3. After manually correcting and redirecting to the proper page, all he links now have 'wp-admin' in them.

I have tried downloading & replacing all the WP core files. I have also added a backslash to 'siteurl' & 'home' in wp-options which now point to http://localhost/ without any success.

  • Have you installed wordpress using wp-config.php ? – Tobias Beuving Feb 26 '16 at 13:39
  • I don't know any other method to do so. – Nimsrules Feb 26 '16 at 13:53
  • When you say: I have tried downloading & replacing all the WP core files.- did you remove the install and reinstall it via wp-config.php or did you just copy the files? – Tobias Beuving Feb 26 '16 at 15:39
  • I replaced all the files except wp-config and wp-content – Nimsrules Feb 27 '16 at 8:50
  • 1
    If you can I recommend to trash everything and do a total clean install – Tobias Beuving Feb 29 '16 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.