Many Wordpress functions follow naming conventions, probably the most well known of these would be the the_*()
functions, such as the_post()
, used in The Loop.
Obviously the is_*()
family of functions belong to the Conditionals. However, what are the common themes represented by the following function prefixes:
add_*()
register_*()
wp_*()
wp_insert_*()
It seems to me that the wp_insert_*()
functions all perform INSERT
statements on the database. That is, they change the state of the application. Is this correct?
It seems to me that the register_*()
functions do not affect the database. That is, they make constructs available for the current page call only. Is this correct?
Is there a common theme for the wp_*()
functions? Is this just an old pseudo-namespace that is no longer enforced?
The add_*()
functions seem to be the most illogical. Some affect the database, such as add_post_meta()
, and some don't add_theme_support()
. What is common among the add_*()
functions, and why aren't they called i.e. wp_insert_post_meta()
and register_theme_support()
for consistency?