1

I am trying to render content generated by a php file in [jQuery Colorbox][1] through AJAX in my WordPress site. The PHP resides on the same server in the same domain. It works perfect when I run it on localhost but it's not working on the server.

Here is the link to my site - http://shabdcreatives.com/portfolio

The links themselves are not invalid, for example the following link works fine on its own:

http://shabdcreatives.com/wp-content/plugins/catgrid/includes/CatGridPost.php?ID=33

I just won't open inside the colorbox.

Also the php file I am trying to load is just a fragment and DOES NOT CONTAIN any or tags.

I tried the colorbox support group but no replies from them yet

This is the code in the CatGridPost.php file that i am calling in the colorbox.. i tried calling a plain text file too... it returned no error.. but the colorbox did not show its contents either

require_once("../../../../wp-blog-header.php");
$thepost = get_post($_GET["ID"]);
$thecontent = $thepost->post_content;
$thetitle = $thepost->post_title;
$thelink = get_permalink($_GET["ID"]);
?>
<div id="cg-post-container">
<div id="cg-post-title">
<a href="<?php echo $thelink; ?>"><?php echo $thetitle; ?></a>
</div>
<div id="cg-post-content">  
    <?php echo $thecontent; ?>
</div>  
</div>

1 Answer 1

3

You should not load wp-blog-header.php yourself.

Use wp-admin/admin-ajax.php instead, as described here:

http://codex.wordpress.org/AJAX_in_Plugins

5
  • im sorry i dont understand wot i have to do.. plus it is working just fine on localhost... please can u elaborate more.. i dint get it through that link
    – ansh
    Commented Jul 3, 2011 at 16:43
  • Since you're loading WP manually, it's sending a 404 header, while also outputting the correct content. Let me know what exactly is unclear in the tutorial I linked to.
    – scribu
    Commented Jul 3, 2011 at 17:08
  • i dint get what exactly i hv to modify.. just the php.. or the colorbox js? .. im sorry . im a newbie.. :S
    – ansh
    Commented Jul 3, 2011 at 17:15
  • I would suggest getting the code on the codex working, then figure out how to modify it for your case.
    – scribu
    Commented Jul 3, 2011 at 17:19
  • yea i got it to work... thanx.. i shouldnt have loaded wp-blog-header.php
    – ansh
    Commented Jul 4, 2011 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.