0

I've changed my WordPress Address (URL) to just http:// it was http://www. which is causing issues.

However once I've changed it to http:// it reverts back to http://www.

I've tried doing it from the dashboard and also tried replacing all the URLS in the database and again it just reverts back for some reason....

Any ideas?

2
  • 1
    When you say it reverts back, can you explain what you mean? Do you mean when you visit the frontend it uses www. urls? Do you mean the value in the backend has www. and the change does not save? How are you changing the URL? What are you using the replace the URLs in the database? Is it a single site or a multisite? Please try to answer all of those questions or as many as you can, and edit your question to include the answers rather than responding in the comments
    – Tom J Nowell
    Feb 19 '16 at 0:57
  • You might want to check out https://interconnectit.com/products/search-and-replace-for-wordpress-databases/ - it will search your entire database and allow you to get rid of any references to the www address.
    – david_nash
    Feb 22 '16 at 0:28
0

You should check your .htaccess file at the root of your domain. To remove www. you could add something like this:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.example.com$ [NC]
RewriteRule ^(.*)$ http://example.com/$1 [R=301,L]

Alternatively, it could be a setting from your web host's panel. For example, DreamHost has the option to add or remove "www." from urls on a per domain basis. I would imagine this per- domain setting via your web host would take precedence over .htaccess although if someone knows more about that, please chime in.

Your web host may be set up a different way so it wouldn't hurt to check with them to see if there is some setting(s) you are unaware of.

While this post by Paul Lund explains how to ADD "www." the overarching message is to make sure your links are consistent:

http://www.paulund.co.uk/add-www-subdomain-to-all-urls-using-htaccess

Personally, I remove "www." — I think people are familiar enough with seeing the domain without it.

It sounds like you have done that in the database so that points to either a .htaccess directive or something in your server configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.