-2

My blog posts index page (http://katievb.com/blog/) is showing only 1 blog post at a time; I want it to show more.

I am currently using X Theme as my WordPress theme, but a similar problem happens even if I try using Twenty Fifteen or Twenty Twelve or other standard themes. (The blog index page still just shows 1 blog post.)

I would think it would show 6 per page like this demo: http://theme.co/x/demo/integrity/1/blog/.

I found this similar (very old) question but it did not help me.

It seems like there is a posts_per_page variable that must be set as 1 right now, and I'd like it to be 6.

But I'm surprised the default would be 1 and that it persists across all themes. Where can I change it, or how can I change my child theme of X?

  • 2
    Maybe this is a silly question, but did you ever go into Customize and change Front Page to "Display a Static Page?" That is the only way I can think that would make it persist across themes (unless you have some sort of plugin interference). – Megan Feb 18 '16 at 2:38
  • 1
    Thanks. Your comment inspired me to go back and look at all the settings again, and I discovered the answer. – Ryan Feb 18 '16 at 3:04
1

I went to Settings > Reading (at /wp-admin/options-reading.php).

I already had these settings:

  • Front page displays:
    • A static page
      • Front page: Home
      • Posts page: Blog
  • Blog pages show at most 1 posts

That last line I had never noticed before (even when looking for it right here in this admin panel)!

Rookie mistake.

I was able to change it to 6.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.