In Settings > General, I change my site to be https:// and now when I go to /wp-admin I get a 404 Not Found.

Is there a way I can revert this? I tried Googling but found nothing :(

  • Maybe you just try following to add in wp-config.php , define( 'WP_SITEURL', 'http://yourdomain' ); and define( 'WP_HOME', 'http://yourdomain' ); , to see if you have at least access again to the back-end. No idea what you already did before that change or was it 'just' a start. (a try won't harm, and if it is not working you just delete those two lines) – Charles Feb 12 '16 at 7:25
up vote 0 down vote accepted

You cannot revert this. You will need to export your database via PhpMyAdmin and find all of the "HTTPS" instances and replace them with "HTTP". I would suggest using something like Dreamweaver or Notepad++ to 'find and replace all'. After you have done that, import your database again.

  • damn, ok, a fresh re-install it is :( – J86 Feb 11 '16 at 14:54
  • I don't think you need to reinstall. Just change the part of the URL back to what you need. – rocketman7k Feb 11 '16 at 14:55
  • I'm on IIS, I don't have PhpMyAdmin. – J86 Feb 11 '16 at 15:53
  • 1
    @rocketman7k , What? I hope you are kidding, no export needed!. When you can do an export in phpMyAdmin you can also do a search! Like this: In your database you do a search for siteurl which will point you at the table wp_options and says: 1 match in wp_options. Do the same with home and the results will show also 1 match in wp_options. Click both times, Browse and Edit, make the changes and save. Btw, Dreamweaver was also a joke I hope. – Charles Feb 12 '16 at 7:40
  • I reinstalled. All is back to normal now. – J86 Feb 12 '16 at 10:35

the best way is to login to your database, usually thru PHPmyadmin.

Go to your website's options table and edit the option_value for 'siteurl' and/or 'home' to the URL without https:// (just http://)

  • 2
    when you change the options in Settings > General, it only changes the siteurl and/or home fields. And/or because there are two fields you can change – forlogos Feb 11 '16 at 14:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.