1

Just installed WP in Ubuntu 15.10 desktop on my local, home PC. It's the first time I install this CMS in Linux.

After install I came to delete the two native plugins, Aksimet & Hello Dolly.

In the first time I did so I was (strangely) asked to fill in FTP credentials. Since I have no FTP I ran the FTP problem in Google and after some reading added define('FS_METHOD', 'direct'); in the end of wp-config.php ... It solved this prob, but then came another - an error this time, occuring when I try to remove these two plugins:

Plugin could not be deleted due to an error: Could not fully remove the plugin(s) akismet/akismet.php, hello.php.

did sudo chown benwork -R . and also sudo chgrp www-data -R .

Nothing seems to help. Will thank you for your help,

1

You need to make sure that the folder permissions/ownership are correct. Run this command to set ownership:

chown -R apache:apache /var/www/wordpress/
  • 1
    +1 but this depends on the actual user under which the websrver runs – Mark Kaplun Apr 11 '18 at 14:31
  • @MarkKaplun agree. In my case all plugins were owned by "apache" user, except one, owned by "nobody" user. – Eugene Kardash Apr 12 '18 at 15:15
0

Simple solution to this kind of mess that I use, is to have a local FTP server but limit it to the local machine.

Your problem is probably due to still some bad permissions, but I really don't like the idea of reducing security just to have nicer update experience. (If you set properly the direct access setting then every security flow in plugins themes might be used to write to your disk out side of the uploads directory)

-1

This issue probably seems due to permissions of the wp-contents/plugins folder. BTY, check below plugin for remove unwanted plugins call Unwanted Plugins Remover. With this plugin you can remove unwanted plugins on a WordPress core upgrade process. Unwanted plugins are for example Akismet or Hello Dolly.

There is the plugin Unwanted Plugins Remover. It will remove the plugins Akismet and Hello Dolly on every upgrade. You can filter the plugin list to match only one of those plugins or to add more.

NOTE:

This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

  • What you say is interesting. When I changed all my sites folder recursively to 7...55 it still couldn't remove them, but when I changed the plugins folder under wp-content to 77...5 it did work. – user87795 Feb 2 '16 at 22:07
  • No need to change permission whole site folder, just wp-contents/plugins only. See my answer first line This issue probably seems due to permissions of the wp-contents/plugins folder. – AddWeb Solution Pvt Ltd Feb 3 '16 at 5:15
  • I think I changed the whole folder after still having problems when changing permissions only for the plugins folder - I also couldn't update the core etc... Now I can basically I can do changes to the system only when the site's folder is 77...5 but not 7...55 . – user87795 Feb 3 '16 at 6:10
  • Okey, Once you done then check wordpress folder/file permission scheme. Cheers! – AddWeb Solution Pvt Ltd Feb 3 '16 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy