I am trying to connect my site's RSS feed to Mailchimp, but my feed doesn't pass basic RSS validation (http://testrtc.com/feed).

The reason for that is 3 empty lines at the beginning of the feed, which I am clueless as to where they came from.

I tried disabling all plugins but the result is the same. Assuming the culprit is my theme - where should I go search for it? My theme has no feed*.php files in it.

  • Most likely it is a problem with BOM character. make sure all your files are saved as plain utf-8 or ansi Commented Feb 1, 2016 at 14:52
  • No :-( All files are pure ANSI with no BOM character in there at all Commented Feb 15, 2016 at 12:51

1 Answer 1


Found the culprit.

functions.php had a few extra blank lines after the closing ?>

Once removed - it worked well

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.