-3

UPDATE -Feb 2

I've recently brought it back over to a testing server instead of a localhost environment. The address is http://onlinewebdraft.com/nuggettesting/

I have renamed my plugins folder and my genesis and genesis child folders to deactivate them but I still get nothing.

enter image description here

This one is a doozy and I'm willing to offer some points for the right answer (I can do that right?).

I had a website up (no point giving the link as it's just a landing page right now) and something happened to it. It was just a blank page when you visited it. It's a website I put up in the spring for my parent business, so thankfully they understand and I can work on trying to figure this out.

Steps I took to see if I could get it back up and running (as I have all my files and info on my server and can see it via ftp) is:

  • Deactivate all plugins
  • Deactivated/Deleted my custom theme (Genesis framework & Back Country theme for those of you who know Genesis)
  • Renamed my .htaccess file

I'm not really quite sure what is happening so I though if I were to take a copy of my files and backup my database to my local server and set it up locally then I could further diagnose what might be happening to this website. However I can't seem to figure out why my wp-admin isn't coming up or for that matter anything.

I've followed the steps here in order to get a backup of the files I have on my local server.

When I try to bring it up on my localhost all I get is "This webpage is not available".

enter image description here

I know my localhost is up and running as I check out any other localhost web sites I have and everything is running fine.

I've checked my error_log and these are the last couple thigns it's been complaining about

[15-Jan-2016 11:41:01 UTC] WordPress database error Got error 28 from storage engine for query SELECT t.*, tt.* FROM ng_terms AS t INNER JOIN ng_term_taxonomy AS tt ON tt.term_id = t.term_id INNER JOIN ng_term_relationships AS tr ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('category') AND tr.object_id IN (134) ORDER BY t.name ASC made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/genesis/page.php'), genesis, get_header, locate_template, load_template, require_once('/themes/genesis/header.php'), wp_head, do_action('wp_head'), call_user_func_array, WPSEO_Frontend->head, do_action('wpseo_head'), call_user_func_array, WPSEO_OpenGraph->opengraph, do_action('wpseo_opengraph'), call_user_func_array, WPSEO_OpenGraph->category, get_the_category, get_the_terms, wp_get_object_terms

[25-Jan-2016 19:53:28 UTC] PHP Fatal error:  Call to undefined function get_term_meta() in /home3/ambergoo/public_html/nuggetcity/wp-content/themes/genesis/lib/admin/term-meta.php on line 253

I have all my tables imported into my localhost database, I've renamed my htaccess file, renamed my plugins folder and deleted everything but the twenty twelvetheme in my localhost server so I'm not sure what else I can do?

I hope this is enough information to get some direction as to what might be happening as I do not have a backup of the site (the only website of the few I have that doesn't have a backup of course!).

ANY help is appreciated. I'm desperate.

UPDATED

Still no luck. I've started with a fresh install even and removed all but one theme (now I've added a NEW genesis framework and backcountry theme (what I had before) but I have no way of hooking it up as I can't get to the front end..

Here is a screenshot of my initial setup.

enter image description here

I don't understand it but whatever I do I can't seem to connect my front end to the content and information I see in the correctly chosen database from my wp-config.php file. I know the info is in there as this is the database and the tables I'm trying to call.

enter image description here

UPDATED - as per a comment from BillK

I'm able to visit any other localhost site but my nuggetcity one.

nuggetcity enter image description here

another one in the same directory enter image description here

UPDATED - as per a comment from AddWeb Solution Pvt Ltd

Here is a snippet from m y apache error log

<IfModule> section
[Fri Jan 29 16:35:30 2016] [error] [client ::1] script '/Applications/MAMP/htdocs/index.php' not found or unable to stat
[Fri Jan 29 16:36:08 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 16:36:08 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Fri Jan 29 16:36:14 2016] [error] [client ::1] script '/Applications/MAMP/htdocs/index.php' not found or unable to stat
[Fri Jan 29 16:50:40 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 16:50:40 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Fri Jan 29 16:56:51 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 16:56:51 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Fri Jan 29 16:57:15 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 16:57:15 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Fri Jan 29 17:02:16 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 17:02:16 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Fri Jan 29 17:03:12 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 17:03:12 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Fri Jan 29 19:18:38 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 19:18:38 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Fri Jan 29 19:35:48 2016] [notice] caught SIGTERM, shutting down
[Fri Jan 29 21:00:44 2016] [notice] Digest: generating secret for digest authentication ...
[Fri Jan 29 21:00:44 2016] [notice] Digest: done
[Fri Jan 29 21:00:44 2016] [notice] Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/0.9.8y DAV/2 PHP/5.3.6 configured -- resuming normal operations
[Fri Jan 29 21:01:34 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Fri Jan 29 21:01:34 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
sh: /usr/local/bin/zip: No such file or directory
sh: /usr/local/bin/unzip: No such file or directory
[Sun Jan 31 16:46:33 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Sun Jan 31 16:46:33 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Tue Feb 02 16:08:25 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Tue Feb 02 16:08:26 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Tue Feb 02 16:12:15 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Tue Feb 02 16:12:15 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Tue Feb 02 16:12:15 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Tue Feb 02 16:12:15 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Tue Feb 02 16:12:26 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Tue Feb 02 16:12:26 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
[Tue Feb 02 16:17:53 2016] [error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/2016/.DS_Store
[Tue Feb 02 16:17:53 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: </IfModule> without matching <IfModule> section
  • 3
    putting bounty over a off topic question (too localized) is unlikely to change the nature of it and make answer more likely to actually help you. – Mark Kaplun Feb 2 '16 at 6:11
  • Consider directing your question to Serverfault as the nature of your errors suggest the issue to stem from your hosting environment rather than WordPress. Before you eventually bring the production site back online, be sure to replace all of the security salts, since your screenshots disclose them as well as the name of the relevant company - the site will be widely vulnerable to malicious attacks if the salts remain as they are in the screenshot. – bosco Feb 2 '16 at 20:28
  • Port What? What does it show when you go to http://localhost:8888/2016/nuggetcity - that's a big difference if your server is running on a host:port. – jgraup Feb 3 '16 at 0:21
  • Another idea is to Install wp-cli.org and run wp --debug. I actually found some errors that would have never shown otherwise. – jgraup Feb 3 '16 at 0:24
  • Thanks for the comments guys and the suggestion bosco (I will be changing everything around on it after this is done). As for what it shows me, I've updated my question with a screenshot of what it shows on the localhost when I visit the localhost:8888/2016/nuggetcity directory (although it has a bit of a different address in that screenshot, it looks the same) jgraup. – kia4567 Feb 3 '16 at 0:26
0

The message displayed by Chrome in your screen shot indicates the problem is more likely a network / server issue than a problem with the website. The puzzling part is you say you can open other sites on localhost. Do you access those sites the same way i.e localhost/someotherdir?

What happens if you type http://127.0.0.1/2016/nuggetcity?

Look for error messages in Chrome's developer tools / console.

Check .htaccess files in the server's root directory.

  • Thanks for the suggestions BillK. I use localhost:8888/2016 to get to my most recent sites of which I have no problem getting to any of my other 4 sites. I've updated my questions with a couple screenshots and the error I get when visiting nuggetcitys path. – kia4567 Feb 3 '16 at 0:14
  • I've manually moved it to an online server. You can check the first part of the question with my newest update. Thanks for helping! – kia4567 Feb 3 '16 at 1:25
  • Thanks for your help but I have figured it out finally. – kia4567 Feb 3 '16 at 7:52
  • Would you care to share what was causing the problem? – BillK Feb 3 '16 at 8:55
  • I'm not sure what was causing the problem still but I know what fixed it. I've posted an answer on the steps I followed to correct it and regain control again. – kia4567 Feb 3 '16 at 9:10
0
+150

For error: WordPress database error Got error 28 from storage engine Solution: The error come when MySQL doesn't have any free hard disk space to write to. Check your /tmp directory, that's where I had run into problems. Once clear and restarting mysql should look working.

You can check disk space via command line:

myServer# df -h

Don't forgot to check .htaccess file. Compare and correct it with your domain.

For error: PHP Fatal error: Call to undefined function get_term_meta() Solution: Check for your genesis update where as in your case you removed it but you need to update it whenever you use.

Basic .htaccess content like: Your server log says :

[Tue Feb 02 16:17:53 2016] [alert] [client ::1] /Applications/MAMP/htdocs/2016/superclean/.htaccess: without matching section

Without check your .htaccess file code, I can suggest you:

1. Either try deleting/renaming your .htaccess file.
2. OR replace your .htaccess content with below basic content.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

You can share you .htaccess code if above any option not working. So we can drill down for proper solution.

Let me know if there is any concern from above!

  • Thanks for the reply and suggestion although I'm not sure what you mean by the /tmp folder (where is that?) and the command line snippet you provided... I've checked for an .htaccess and none exist as I've removed all of them. Should I have an .htaccess to point to the localhost domain? I've also updated the question with more of my findings. Thanks so much for the help, this is driving me absolutely crazy! – kia4567 Feb 1 '16 at 0:55
  • If your WP without custom URL then no need to .htaccess. You can see how to clean up tmp – AddWeb Solution Pvt Ltd Feb 1 '16 at 5:25
  • I really have no clue how to do any of that. I can open up my terminal (I'm on a mac) but not sure even how to get past the first part and whatever I do my username continue to appear there. Shouldn't I be able to hit the enter button then start writing a command? – kia4567 Feb 2 '16 at 0:53
  • Let me what your Apache logs says? Also just try to run wp-admin/install.php and what is also say? – AddWeb Solution Pvt Ltd Feb 2 '16 at 5:34
  • Either the web server isn't actually working, could be something else is using port 80 like Skype, or Chome is just being mean. Try localhost and see if that takes you to where you want it to go. – AddWeb Solution Pvt Ltd Feb 2 '16 at 5:42
0

I have found out how to fix it but can't seem to find out what caused it. The website was fairly new and was launched on April 20th, 2015. Not many updates had been done so maybe thats why?

Someone had suggested that I replace all instances of the wordpress core files (except wp-config.php and wp-content as these are important for your website and without them you don't have your custom website).

So you:

  • Go to wordpress.org and download the latest copy of wordpress
  • Unzip the folder and extract the files
  • Visit your website (I had a copy of my files on a different server to play with and test - i manually moved it over with the help of this article but don't forget to change your URL's)
  • Replace every file and folder (except wp-config.php and wp-content) with a fresh install of wordpress
  • Follow the rest of the steps in the manual migration article I referenced earlier. Don't forget about the URL change if you moved to another server for testing.
  • Refresh the page where your wordpress website should be
  • You may get a wordpress notification about repairing the database, run the repair and all should be good.

So I was able to do this on the test site I put up earlier and then after visiting the site and repairing the database all was well.

I'm not quite sure now what caused the white screen of death, but a fresh update of wordpress did the trick.

So now, either install your backup plugin (I use Backup Buddy) or manually migrate these files back over (in the same fashion) to your actual website server.

Hope this ends up helping someone.

-2

Try remove the genesis theme folder and see what happens. Make sure you have the default WordPress theme folders under /wp-content/themes/

  • Thanks for the suggestion Emanuel. I've already made it so I only have a twentyfourteen theme in my wp-content/themes folder. – kia4567 Jan 30 '16 at 3:19
  • Then maybe you have a cache in place because the error message is clear: /home3/ambergoo/public_html/nuggetcity/wp-content/themes/genesis/lib/admin/term-meta.php on line 253 – Emanuel Rocha Costa Jan 30 '16 at 16:40
  • 2
    This is nothing more than a comment – Pieter Goosen Feb 2 '16 at 9:23
  • 2
    Furthermore, there's really no need to completely remove a theme directory in the process of troubleshooting - deactivating the theme should be sufficient to prevent any of it's scripts from executing, unless they're explicitly referenced by an external plugin (in which case the installation has some serious design issues). – bosco Feb 2 '16 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.