0

I have just updated wordpress 3.8.1 to 4.4.1. Tried to update in various ways:

Before updating I have deactivated all the plugins and switched to the default theme provided by wordpress i.e. twentyfourteen.

Option 1: Update wordpress automatically. Files are updated successfully as I can the see the message. But it keeps loading with the message "Updating database .." (something like this) and database is not updated even waiting for an hour.

Option 2: Update manually: Copied files (wp-includes,wp-admin folders, and default files of the root, first deleted these then copied from latest version). Site works fine with the changed theme. While logging into the admin there is a message asking to udpate the database. However page keeps loading without any update in database. Now admin does not work at all. I can neither see the database update link nor admin dashboard, page keeps loading.

Has anyone gone through such issue?

Thank you for help.

  • Did you check after clear browser cache? There is may be issue with cache. – AddWeb Solution Pvt Ltd Jan 28 '16 at 7:11
  • Thanks for the response @AddWebSolutionPvtLtd. It seems not the issue of cache. – user478 Jan 28 '16 at 22:09
1

In general, it is a bad idea to upgrade from such an old version to new version in one go. In your case, a huge amount of changes was done between the release of v3.8.1 and v4.4.1 which invloved changes in the db.

I'm not sure which is the best option here to repair the db as it seems that you cannot log into the site. What I would suggest is, revert back to v3.8.1 and get everything running again. At this stage, it would be good idea to download, install and run a plugin like DB Manager (to which I have no affiliation to) to repair and optimize your db.

Once this is sorted, you will need to manually update WordPress in steps. Download all major versions between v3.8.1 and v4.4.1, so would download v3.9, v4.0, v4.1 etc. You should then start by upgrading to v3.9, after that, upgrade to v4.0 until you are fully upgraded.

Once done, you can rerun DB Manager.

TIP:

Since a huge amount of changes between v3.8.1 and v4.4.1, it would be a very good idea to download and install Debug Objects to catch any bugs as there was a lot of depreciation done between those versions. Make sure that you catch and repair all those bugs

  • Thanks @pieter. I just updated the db version in wp_option table and now I can login to admin. However I don't think the database has been updated properly the way it should be. Currently I am working on my local server. And I am have having issues like – " Fatal error: Call to undefined method stdClass::filter() in D:\wamp\www\mysite\wp-includes\taxonomy.php on line 805". I thinks this should not be something related to database update. I have another test site in local in which I updated wordpress and that is working perfectly fine. I think I should try updating WP as you have mentioned. – user478 Jan 28 '16 at 22:18
  • That would definitely be a good idea. If you follow what I said, you should be able to sort your issue ;-) – Pieter Goosen Jan 29 '16 at 4:34
  • Updating WP to 4.2 and so on, database update doesn't work while updating from wp-admin, need to update manullay changing db version in wp_otion table. Now there is another issue for which I have created another question wordpress.stackexchange.com/questions/216282/…. @pieter Goosen can you please help me on this matter. Thanks again – user478 Feb 1 '16 at 5:45
  • If this is issue is resolved, accept the appropriate answer or post and accept your own answer ;-) – Pieter Goosen Feb 1 '16 at 11:29
  • In my website there are about 25 plugins running including the custom plugins developed for the various purposes. Automatic database update works upto version 4.1.9 and from version 4.2 to the latest (4.4.1) manual update in database works. Just need to update db_version in wp_option table from the wp-includes/version.php. However if fresh wp of version 3.8.1 is updated to the latest version then it works perfectly without any manual update. So it seems it depends upon the plugins installed on the site. Hope this will help to others if needed :) Thanks everyone for the comments and suggestions – user478 Feb 1 '16 at 23:53
0

You can solve issue by this way(If issue with plugin/theme related):

Deactivating your plugins by ftp or the file manager by changing the name of the plugins folder to plugins-old. If that works activate them one by one until you find the problem.

Switch theme to any default (just for a moment) by using ftp or the file manager on your hosted account to change the name of the current theme. That should force wp to open with the default theme.

Hope this work for you!

  • I have tried this but does not work. I am not sure if the issue is related to plugin/themes or anything else. I am looking into it further to find out the solution. Thanks – user478 Jan 28 '16 at 22:29
  • Is there any log entry with error? Please check log file. Also check version.php in wp-includes directory verify if the wp_version and DB_version is the SAME in your website. – AddWeb Solution Pvt Ltd Jan 29 '16 at 5:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.