0

For some reason I have to specify fort :80 in the name of the website. Otherwise, nothing works. However, this port is then included in the permalinks and in the sitemap etc. Is there a way to get rid of the port in the website name without destroying the website?

Thank you

0

Here are some additional details that step you through transfering a LAN-based wordpress site into an externally accessible site as well enabling editing the wordpress site from inside the LAN.

Two important keys are router/firewall modifications and the "wait 10+ minutes" after making the changes at the end.

-using ssh to log into your server (nano is a server preinstalled text editor) -$ nano /var/www/books/wp-content/themes/twentyeleven/functions.php -add lines just after

update_option('siteurl','http://your.site.url:port/yourblog');
update_option('home','http://your.site.url:port/yourblog');

-refresh your web browser using your external site url

http://your.site.url:port/yourblog -$ nano /var/www/books/wp-content/themes/twentyeleven/functions.php -remove those lines you just added (or comment them out) -access your router (these steps are for pfSense, other routers should have similar settings to look for/watch out for) -add to firewall/nat table a line like this

    wan/tcp/port/LAN.server.IP/80

-add to firewall/rules table a line like this

    tcp/*/port/LAN.server.IP/port/*

-uncheck the box at System/advanced/network address translation/Disable NAT Reflection

   "Disables the automatic creation of NAT redirect rules for access to your public IP addresses from within your internal networks. Note: Reflection only works on port forward type items and does not work for large ranges > 500 ports."

Then go do something for ten minutes and when you get back see if the external url http://your.site.url:port/yourblog from a LAN browser brings the page up correctly.

You can read more about permalink Here

  • Yeah but after I change the url, the website gets 301 permanently relocated error and it stops working. – Mikhail Kashtaev Jan 25 '16 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.