0

I have a Wordpress theme I'm working on. All of a sudden there are random ASCII characters overlapping the nav tabs inside the hamburger menu, font-awesome characters, and social icons.

I have tried restoring the mySql database, deactivating all the plugins, and restoring file on the server to reset.

Here is the site

Thanks in advance.

  • I see a blank, purple site when following the link. (I have JavaScript disabled by default on unknown sites.) So even I could inspect the site, there's no question here that I could answer. Please provide some technical details what you've tried so far, what you expect and what happened instead. – David Jan 20 '16 at 16:10
  • @David turn on your js so you can see the random generated ascii characters in the menu and other spots on the site. I have tried restoring the mySql database, deactivating all the plugins, and restoring file on the server to reset. – RLM Jan 20 '16 at 16:16
  • Well »random generated ascii characters« could be a symptom of a hacked site, so I'm not going to enable my JavaScript. Why should I? Please provide the relevant markup and the code that is responsible for this markup and you will get help here. – David Jan 20 '16 at 16:23
3

It seems that error is in your theme.min.css. The Font Awesome Icon which should appear in the browser is added via CSS using content. But the CSS does not contain the icon information but these weird looking characters.

For Example: .fa-music:before{content:"�"}

I cannot tell why your minified CSS has these characters. This could be:

  1. a bug by Font Awesome
  2. or your CSS Minifier is not working correctly.

In addition, I see you include Font Awesome Version 4.4.0. You can try and upgrade to the latest Version 4.5.0, which is available at http://fontawesome.io/

  • I actually figured it out already. You are correct, sir. It was a matter of installing the latest font-awesome CDN. Thanks so much for looking +1 and I'll give you the accepted answer. – RLM Jan 20 '16 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.