0

I am trying to import posts from one of my WP sites to the other. The XML File was around 80MB so I split them in to smaller Files of 2MB Using a WXR Splitter.

I then imported them on to the new site. I get the message that says all done, but when i check i cannot find any posts on the front-end or the admin end. The posts however, did appear in the database when I checked. Is there any possible solution for this?

0

The issue seems to may be with identical post_date on both a revision and a post. As the data is transferred into the DB, the revision goes first and when the post hits it, the DB sees it as already existing and so does not transfer the actual post.

First check:
Post type
Date

I'm not sure how it ended up with duplicate dates and times but, in my case, I think it has to do with moving some of these posts multiple times - out of and into different test blogs during development.

The solution I used was to go into the exporting DB prior to export and delete anything where post_type = "revision". Then do the regular WP export / import.

Should work fine.

| improve this answer | |
  • Hi @addweb Tried what you suggested. Removed all the revisions from the database and tried to import. The same problem still persists. The media is getting imported but the posts are not. – Jerold Vaz Jan 12 '16 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.