10
votes

It seems that depending on which default language I've set Polylang to, all my uploaded images are isolated so that I can only pick them when I'm editing posts in the default language.

I have a lot more images shared/in-common between English and French posts than images specific to a single language.

Is there any option to show all images regardless of which language I'm currently editing in Wordpress?

enter image description here

It's very likely I might of just uploaded them in the media library when I was currently editing a post (in which case, maybe it isolates the images to be available only for that particular language & given post?) if so, I may have an entirely different problem on my hands.

Is there a way to simply show ALL assets?

4
  • 1
    Support is pretty good on wordpress.org/support/plugin/polylang, have you tried asking there? Show all languages usually removes the filters in the backend. If you're looking for a file try the search field and maybe you're correct that it didn't attach to a post.
    – jgraup
    Dec 10, 2015 at 19:09
  • 1
    Just found the answer actually, will post it up in a sec. Dec 10, 2015 at 19:14
  • Oh, and actually this seems to be a duplicate! My bad... Edit However it exists on stackoverflow (not the WP stackexchange) stackoverflow.com/questions/24753339/…, so I wonder if I can repost the answer? Dec 10, 2015 at 19:16
  • Noting that while this and other 3rd party plugin questions are off-topic, I've locked it as it has lots of upvotes and views. Users of Polylang should use the official support routes or ask in Polylang communities
    – Tom J Nowell
    Feb 23 at 16:42

1 Answer 1

14
votes

From this post at wordpress.org/support, the user Chrystl points out:

If don't need to translate your media titles, uncheck this option:

In Languages > Settings tab > Media: "Activate languages and translations for media".

And you will access to your entire library by clicking on "Add media" and "Set featured image".

And that indeed did the trick for me! :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.