I released a new plugin to the .org repository about a month ago, and have committed several new versions since then, but the pie chart on the stats page has always stayed at 100% for an arbitrary version. For example, a week or so after 1.1 was released, it said that 100% of users had 1.0 installed, and recently it's been saying that 1.1.2 has 100%. I released 1.1.3 yesterday and it's gotten about 75 downloads so far, but the chart still says 1.1.2 has 100%.

I realize there's probably some caching going on, but there's obviously a problem. It has around 1000 total downloads spread out over 5 releases, and we know that users don't update very frequently, so the chart should show the numbers spread out more. I'm guessing the next time it updates it'll say that 1.1.3 has 100%, like it's done for previous versions.

Am I doing something wrong in my readme.txt or main PHP files? I've always had Version: [current version number] in the main PHP file and Stable tag: [current version number] in the readme.txt, and the readme.txt passes the validator.. You can browse through the different versions at http://plugins.svn.wordpress.org/basic-google-maps-placemarks/tags/.

Update: The File Header page in the codex has a specification, which can be helpful in debugging issues.

Update 2: Now it's stopped working again. It might just take a couple releases with the fixed headers to work, though.. I finally fixed it; see my answer below.

2 Answers 2


I guess the following things could be a problem:

  • Adding : after header comment "keys"
  • Not using all possible header comments - WP reads the first 8bit (in a not really pleasent way), but I don't know how the repo does
  • Move the /* into the same line as the <?php tag

If nothing of these are part of the problem, then i don't know and you should consider contacting the hackers list with this issue.

Edit: One problem I have myself is that the repo is telling me that i have to upgrade one of my own plugins to some complete other. The solution was changing the folder name to something less general.

  • Btw: Cool donation link/idea :)
    – kaiser
    Commented Jun 27, 2011 at 1:36
  • I don't think the semicolons or having the opening multi-line comment indicator are the issue, because the Codex example uses them. I did leave a couple of the attributes out (on purpose), though, so I'll try adding them in and seeing if that helps. It may take a couple releases to properly test if that solves the problem, though.
    – Ian Dunn
    Commented Jun 27, 2011 at 16:01
  • Codex is written by normal people like you and me. Some pages are outdated, others are incomplete and most are missing edge case scenarios. I'm pretty sure the first won't help much, but maybe the point filed under "edit" will. Anyway: I'd contact hackers about the issue and leave it to them.
    – kaiser
    Commented Jun 27, 2011 at 16:15
  • Cool, thanks. I don't think I'm having the same issue that you mentioned in your edit, since the folder and main php file are both named "basic-google-maps-plugins", and I'm not getting any upgrade notices.
    – Ian Dunn
    Commented Jun 27, 2011 at 16:28
  • 1
    It's working now. It looks like the missing attributes were the problem. Thanks :)
    – Ian Dunn
    Commented Jul 3, 2011 at 16:02

I was wrong earlier when I said that it was fixed. It kept happening, but I finally fixed it by changing the files from using Windows line breaks to Unix ones.

  • Well that probably answers my question. Did you have to do this in ALL versions of the plugin or just the most recent?
    – mrwweb
    Commented Jun 1, 2012 at 16:08
  • I only changed the most recent version, but then it took a couple releases for the impact to take effect. Even if you updated the old versions in the repo, I'm not sure it'd help anything since it wouldn't change the copies already installed in the wild. I also have a hunch that the header parsing is normally inaccurate and buggy to some extent due to the loose nature of the format (as opposed to something strict like XML), and that that plays into this issue.
    – Ian Dunn
    Commented Jun 2, 2012 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.