0

I read a lot about Wordpress not sending mail, but often the solution is in server configuration that is not my case.

My wordpress site isn't sending registration mail, but works perfectly in sending 'lost password' email. I'm a bit confused and i do not really know where to look to understand where the problem is. There are no errors in console in registration page. What i should check in a case like this?

  • 1
    +1 to actually having a question, but most likely this will get voted as too localized. Obvious step is turn off plugins, and inspect the error log, but beyond that it will be hard to give a general advice without knowing your setup. – Mark Kaplun Dec 9 '15 at 11:23
  • Ehehe, I imagined that, but i'm nearly a beginner with wordpress... Even the suggestion to turn off the plugin is great to me. I didn't know there was actually an error log. Can I ask you where to find it? I tried enabling WP_ERROR true but it just don't say as much as i wanted it to. ^^ – Sasha Grievus Dec 9 '15 at 12:19
  • 1
    not a wordpress specific log, just the normal php error log. You can also use WP_DEBUG - codex.wordpress.org/WP_DEBUG, but it sounds like if there is an error it is at php level itself. – Mark Kaplun Dec 9 '15 at 12:38
  • Oh, yes, i meant wp_debug. It's so strange to me wordpress not having an own error log, easily accessible... Btw, i found the problem. A plugin was blocking system sending email to replace it with is own. Turning off plugins saved the day. Thank you very much. (For people passing by:the plugin was Cimy User Fields. If you don't check the apposite option, it automatically turns off email verification at registration) – Sasha Grievus Dec 9 '15 at 13:08
  • First, check in junk mail folder. – Agniswar Chakraborty Jan 13 '17 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.