0

I've met a strange error on my page. After I do an internal link in my site, like that in the page editor

<a href="/page-name">

then in the page source code it displays

<a href="/?page_id=784">

instead of the slug.

Have anyone met something like that? How can I change that to display slug instead? I got the permalink setting %postname% and all other internal link displays fine, just that one...

  • What do you mean ? I got line like that <p class="contact-visit" style="text-align: center;"><a class="hover_orange" href="odent.pl/profil-pacjenta/umow_sie" target="_blank">Umów Wizytę</a></p> but instead I got the ID in the page source code – Mateusz Winnicki Nov 26 '15 at 13:37
  • ' Added slash, so editor don't convert it into a code, it is not an error ;) ' - i meant stackoverflow editor ^^ i dont have that in my code. I even changed that in my database manually... but still doesn't help ... I'm using page builder – Mateusz Winnicki Nov 26 '15 at 13:47
  • yea, but It still doesn't help with the problem ^^ – Mateusz Winnicki Nov 26 '15 at 13:53
  • nope but will hopefully help others get a better understanding. I will remove my comments now, since it's mainly about the formatting ;-) It could be from the page builder you're using or other plugins, or even the theme. Did you check it without the page builder activated? – birgire Nov 26 '15 at 14:00
  • I think it started to work, after manauall database change...Just had to take some time to refresh on page ... – Mateusz Winnicki Nov 26 '15 at 14:01
1

What your explaining is the normal linking method for WordPress when you are linking to a post that has not yet been published. Based on your question I think that's what occurred to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.