It seems that none of the javascript is working when I log into the admin section of my site. I cannot do anything that requires javascript or AJAX : Nextgen thumbnails, Widget organisation, even the admin menu doesn't work.

The javascript in the front end of the site works as it should.

I looked in firebug for the scripts and found this (obviously loaded in the footer):

<script src="http://kainielsen.web44.net/wp-admin/load-scripts.php?c=1&load=jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,hoverIntent,common,jquery-color,wp-ajax-response,wp-lists,jquery-ui-resizable,quicktags,jquery-query,admin-comments,postbox,dashboard,thickbox,plugin-install,media-upload&ver=e0f647a6df61adcc7200ce17a647db7f" type="text/javascript">

In some way wordpress seems to be trying to load all the scripts at once. Could it be this that is causing the malfunction?

Is this normal Wordpress behaviour? Or could it have come about because I was using W 3 Total Cache ?

The ultimate question is that if loading everything at once is the cause, How do I undo it?

5 Answers 5


Script concatenation in admin area is normal behavior, but I am not sure that trying to load that many scripts is.

You can disable concatenation by defining CONCATENATE_SCRIPTS constant to false. In wp-config.php would be fitting:

define('CONCATENATE_SCRIPTS', false);

See Disable_Javascript_Concatenation in Codex.

W3TC shouldn't affect anything on admin side.

  • What's the script I need to put into config.php. I'll try it, thanks. I asked if it could be W3TC because I remember that it does ask if you want to concatenate scripts (but I can't remember if I'd said yes or no) - as I uninstalled it as part of trying to find the solution, I wondered if it could have left something behind...
    – Nick
    Jun 23, 2011 at 13:15
  • 4
    @Nick something like this define('CONCATENATE_SCRIPTS', false);
    – Rarst
    Jun 23, 2011 at 13:25
  • Thumbs up to @Rarst, i had the same problem on a MU installation and this solved the problem.
    – kevin
    Apr 18, 2012 at 15:43

Most likely, you have a misbehaving plugin. Try disabling all plugins, then see if the problem goes away. If so, then begin narrowing down which plugin causes the interference. If the problem does not go away with all plugins disabled, also try switching your theme to the default to see if it was the problem.

  • My theme is built on the back of 2010, so to all intents and purposes it is the default theme. And I've stripped out all the plugins that don't stop me actually having a site - they all function correctly on the local test site.
    – Nick
    Jun 23, 2011 at 13:11
  • I have to eat my hat !
    – Nick
    Jun 25, 2011 at 8:58
  • The reason was a tiny piece of javascript which the admin side didn't like. I put the script of limits to admin putting the enqueue script function inside an if(! admin) condition - probably a good idea for all frontend scripts. Having resolved the problem, my webhost then wiped my site without any prior warning... so it goes apparently.
    – Nick
    Jun 25, 2011 at 9:07

I had the same problem after migrating from my localhost for a web server.

I noticed that there were differences between the load-scripts.php that was being generated by localhost and what was being generated by the web server. The web server was generating "double quotes" on some parts of que code!

THE SOLUTION (in my case): I compared both php.ini and noticed that on my web server the options of "magic_quotes" were enabled. Disable them (like on localhost's php.ini) and problem solved!


Upload a fresh wp-admin folder. That worked for me. This occurs in some servers due to issues occured during file uploads.


I also pulled my hair out... :) The scripts didn't load on one specific page, especially the scripts wp-media, which lead to the error "wp.media is not defined"... all the solutions didn't work. It turned out the content on this page was too massive, my PHP Memory Limit was to low. Setting up MemoryLimit 256->512 worked for me... Greetings ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.