1

I'm trying to merge an old wordpress blog with a new wordpress site. Effectively all I want is to bring across the posts and link off to them from a link in the navigation called "blog".... simple enough. So I've already exported the posts from the old blog and imported them to the new site via the wordpress importer. That is working and I can see them in my admin panel.

The problem I'm having is I've created a page "blog" but when I attempt to go to this page I get the following error:

Not Found

The requested URL /blog/ was not found on this server.

This makes no sense to me as my permalinks are setup as follows:

http://thesite.com/%postname%/

and every other page on the site works perfectly. No 404s... I've checked my .htaccess file but nothing is jumping out. If I change the name of the page to blog123 then I can go to /blog123 and it works fine.

Can anyone point me into the right direction of what might be happening and how I can go about resolving it?

Many thanks,

Note: /blog is not a subdirectory. The wordpress installation sits in the root. /blog is the name of the page ( I am using custom permalinks).

  • Do you enter the /blog page with 404 by clicking 'view' in the admin menu? If not, try to do that – Jeff Nov 11 '15 at 9:48
  • Hi Jeff yes that results in the same 404 error – Javacadabra Nov 11 '15 at 10:17
  • Are you sure there is not a directory /blog/ on the filesystem? Do you have any other .htaccess files that might be creating conflict? Is there a post you imported that has the slug blog? Have you tried a fresh browser instance/clear cache? – TheDeadMedic Nov 11 '15 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.