I've been given a wordpress site to do some development work on (I didn't do any of the initial development on it). I've installed it locally and am running it with XAMPP on Windows 7. I generated the database from a mysqldump file and I made the changes to wp-config to link to the database. After also changing the URL values in the wp_options table (they were set to the path of the live site) I got it working so that all the posts and settings are are showing up in the wp-admin console. Also on the frontpage the blog item excerpts list is populating correctly and all the layout and images are loading fine. The problem is that when I click through to an article it returns a 404 object not found error. The URL path to the article page looks to be correct.

Would really appreciate it if anyone had any suggestions on what may be wrong and what I need to do get the article display pages working. I figure it must still have something to do with an incorrect base URL path being set somewhere, but can't find any other places where it would need to be changed

Thank you!

1 Answer 1


my first thought is that it is a permalinks issue. if it is, set your permalinks to default and the links should work correctly.

also, be sure to search the database for (and replace) any other instances of the old live site's URL, particularly in wp_posts table. it's easy to forget to update guid and post_content [i.e., UPDATE wp_posts SET guid = REPLACE (guid, 'http://www.livesiteurl.com', 'http://www.newsiteurl.com')]

  • Thanks for the answer. I think you're right -- do you know if there anywhere that logs errors like this so I have a better chance of tracking down which attributes have to be updated?
    – tks
    Jun 5, 2011 at 5:28
  • You just run that query on GUID and post_content. They are the two fields that will have the old URL in it. To get the permalink's working just resave them on their current setting, no need to reset back to default, that will rebuild the .htaccess file. Jun 5, 2011 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.