1

First, context: I am not developing a theme, I am not mucking around with PHP. All I wanted to do was throw up a quick temporary WordPress site in a few minutes, paste my content in, and call it "good enough" for a month until I could sit down and dedicate real time to building a website.

I really liked the look of the free Zerif Lite theme, so I grabbed that. Ever since I have had nothing but trouble.

I created two pages: Front Page and Blog. I intended for Front Page to look like the Zerif Lite front page and for Blog to be... a blog. Simple enough, really. I created a single menu which linked to each page. I then set up my settings like so:

Settings for my WordPress site

However my front page was just an empty blog. There was a default side bar on the right and nothing on the left. It looked atrocious.

I went into Front Page and added some content:

Content added to Front Page

Which didn't show up correctly when I checked out the site:

Why does it look like this?

I've been all over the internet for two hours now and my patience is wearing thin. No one seems to have any answers. The only answers I've found are that a plugin could be causing it (not possible, see my plugin list below) or reinstalling WordPress should fix it (tried this, didn't work)

Looking for any WordPress pros who can help me figure out what on Earth I'm doing wrong

Plugin list:

I only have one

Update

I've tried changing the theme but it still doesn't seem to be treating my front page like anything other than a blog post:

Twenty Fifteen

  • 2
    If the theme gives you much problems, why still use it. Your issue is theme related. – Pieter Goosen Nov 4 '15 at 6:47
  • It seems like your theme css is not working properly. – Rubatharisan Thirumathyam Nov 4 '15 at 8:35
  • @PieterGoosen: I first started noticing the issue upon installing the theme, as the default WordPress install doesn't have a static front page and it was after installing the theme that I tried to set one up. Even using Twenty Fifteen it's showing the front page in blog post style - although at the very least it is keeping my formatting. I'll update the original post with a screenshot. – stevendesu Nov 4 '15 at 13:15
1

I find the solution of your problem. In this theme, you can't set page as home or front page, so your setting in Setting >> reading >> Your latest posts check.

For blog page you can select template in your Blog page Page Attribute Template option as Blog or Blog template with large image.

You can also change your home page content Using the customize option in Appearance >> customize.

I hope it will help you. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.