0

I have a custom post type, list, with 86 posts, none of which show up on the list for its admin page. It just says "List not found". But when I choose "October 2015" from the filter dropdown, all the posts display. Another post type, which is defined in the same way, has the expected display of those posts. Any ideas?

Here's the custom post definition:

function custom_post_list() {

$labels = array(
    'name'                => 'Lists',
    'singular_name'       => 'List',
    'menu_name'           => 'Lists',
    'name_admin_bar'      => 'List',
    'parent_item_colon'   => 'Parent Item:',
    'all_items'           => 'All Lists',
    'add_new_item'        => 'Add New List',
    'add_new'             => 'Add New List',
    'new_item'            => 'New List',
    'edit_item'           => 'Edit List',
    'update_item'         => 'Update List',
    'view_item'           => 'View List',
    'search_items'        => 'Search Lists',
    'not_found'           => 'List not found',
    'not_found_in_trash'  => 'Not found in Trash',
);
$args = array(
    'label'               => 'list',
    'description'         => 'A list of posts with something in common',
    'labels'              => $labels,
    'supports'            => array( 'title', 'editor', 'excerpt', 'thumbnail', 'custom-fields' ),
    'taxonomies'          => array( 'post_tag' ),
    'hierarchical'        => false,
    'public'              => true,
    'show_ui'             => true,
    'show_in_menu'        => true,
    'menu_position'       => 5,
    'menu_icon'           => 'dashicons-list-view',
    'show_in_admin_bar'   => true,
    'show_in_nav_menus'   => true,
    'can_export'          => true,
    'has_archive'         => true,
    'exclude_from_search' => false,
    'publicly_queryable'  => true,
    'capability_type'     => 'post',
);
register_post_type( 'list', $args );
  • Is list one of the reserved terms for WP? – jdm2112 Nov 3 '15 at 21:54
  • @jdm2112 It doesn't look like it but it wouldn't hurt to change it from list to something really unique to see if that helps. – Howdy_McGee Nov 3 '15 at 22:45
  • 1
    Please go Settings > Permalink and click Save button once. – Trang Nov 4 '15 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.