0

I have a very strange problem in my website. Let me figure it out:

Firstly I have an SSL website https://example.com when I log in into /wp-admin i can't see some features like my Media Library or my stats on Jetpack. Everything solved when i access the Administration Wordpress mod without SSL.

The first screenshot shows the SSL condition and the second the nonSSL.

SSL nonSSL

Furthermore, i was trying to change the WordPress and Site Address from General Settings but it was unsuccessful.

Finally, my .htaccess file is :

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

I would like to have every link in my website under SSL protocol.

Any suggestions?

  • You've changed the addresses from general settings, is it also in your wp-config.php file? And is it registering the new https:// in general settings? – Aravona Nov 3 '15 at 9:35
  • I changed my address through general settings from https to http and remove the rules from .htaccess file for HTTPS redirecting, so i could resolve the problem. Also when I'm trying to access example.com/wp-admin I'm redirecting to : example.com/… – Panos Angelopoulos Nov 3 '15 at 9:46
  • what kind of SSL certificate do you have? You might have something on that page which isn't ssl certified so there's a minor chance it's effecting the page - your cert on the address bar can enlighten you to any issues like that. – Aravona Nov 3 '15 at 9:49
  • @Aravona thanks for the reply. My SSL cert is Domain certified Rapid SSL. – Panos Angelopoulos Nov 3 '15 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.