0

I am hosting my site on amazon ec2. I have purchased a domain name via godaddy and have forwarded it to the IP address of my amazon instance. I forwarded with masking turned on so that users do not see the IP in the address bar. It works fine, when I go to mysite.com the content loads.

I now need to change the wordpress address and the site address to mysite.com since they are defaulting to the ip address and i want to use permalinks for the rest of the site. When I do this the site no longer works. Site won't load and I can't access admin.

If I change just the wordpress address to mysite.com and leave the site address as the IP I am given an admin login page with broken css but when I try to use it nothing happens.

I have attempted to change the urls via the admin interface, directly in the database (updating siteurl & home in the wp_options table) and via the wp-config.php. all methods produce the same result.

I see lots of questions posted that are similar to this but seem to find solutions that don't work for me.

Any ideas on what I might be missing here?? I'm kind of running out of ideas.

1 Answer 1

0

Put this in your theme template functions.php

update_option( 'siteurl', 'http://example.com' );
update_option( 'home', 'http://example.com' );
1
  • sadly, this does not work either. it seems to have the same effect as the other two options, it updates siteurl & home in the wp_options database table and that then breaks the site. Nov 3, 2015 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.