0

I am developing a website for my client, and I'm having some issues with the theme upload. The theme I am uploading is from Theme Forest.

I tried to upload via backend of WordPress but file size is too big. So I was trying to upload via FTP and my theme file shows up on my server but not on the backend when I go to switch the theme.

I tried using FileZilla, CyberDuck, and FireFTP and yet the problem persists. I don't have cpanel access for this client and just have the WordPress login and FTP login. What do I need to do?

Update: I checked out a few things and I found out my client has Ubuntu setup as the operating system and I can only access the FTP through SSH. Could this have something to do with it?

  • a theme contains many files in a directory, are you just uploading a zip file? you have to unzip it and upload the whole theme directory. – Milo Oct 27 '15 at 18:29
  • Yes I first tried a zip file but doesn't allow me to unzip via ftp. So I unzipped on desktop and uploaded theme folder into directory. Still doesn't work. – Kaushal Kakadia Oct 27 '15 at 18:51
  • Does it work with all other themes (take the Twenty Fifteen theme for example)? – matthew Oct 27 '15 at 18:58
  • 1
    If you can connect with your FTP client, then your FTP client supports SSH (SFTP). You wouldn't have been able to upload anything otherwise. – Milo Oct 27 '15 at 20:00
  • The 3 basic themes that come with wordpress are showing up on the server side and wordpress side. I know it is not a theme issue cause I uploaded 2 different themes on there and they both don't work. @matthew – Kaushal Kakadia Oct 28 '15 at 13:34
1

If you have successfully uploaded the theme via FTP into the correct directory it should be available to activate.

Things to check:

  • Using your FTP client, you should be able to see the theme directory and all its files under wp_content/themes
  • Make sure the file permissions are correct for WordPress to be able to access the files (you may need to check with your sysadmin)
  • As mentioned in Burgi's answer, make sure you are using the proper folder of the theme (/themename/style.css should be visible)
1

If you have enabled a MultiSite Network, you must first enable each Theme you wish to utilize, under "My Sites", "Network Admin", "Themes".

0

When downloading from ThemeForest the themes can be several folders deep in the download package.

In my case there are additional zips and it is one of these archives that contain the actual theme. If in doubt look for the folder containing the style.css file (highlighted), it is that folder you need to upload to wp_content\themes.

Screenshot showing basic Wordpress theme folder structure

If this doesn't work you may need to check your FTP log for error messages.

  • No the correct file has been placed @burgi. Is there a free ftp client that lets you unzip .zip files? Maybe that is an issue, since I am uploading the theme file. Some files might get corrupted or misplaced I'm assuming. – Kaushal Kakadia Oct 28 '15 at 13:37
  • I'm not aware of an FTP client that performs that function, it isn't normally required. When you extract your theme locally what do you see? Are there any errors listed in your FileZilla console? – Burgi Oct 28 '15 at 14:54
0

Just wanted to say. My answer was that I had aggressive browser caching setup in nginx.

My solution was to open chrome developer tools(inspect), select network, and disable cache.

I think you can probably do a clear browser or control shift R reload as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.