I'm having trouble trying to upload a zip file Wordpress theme that I bought from Themeforest. I'm getting an inactive "upload theme" button, I have tried to reinstall the Wordpress theme three times now, but I'm having the same problem. I also tried uploaded the theme through FTP to "content" folder, but this did not solve my problem. This started when I upgraded to Wordpress 4.3.1. I'm I missing something here? please advice.

enter image description here

  • 1
    The best advice is: ask to the seller for support. There is nothing we can do as we can not know how the theme is coded or zipped.
    – cybmeta
    Commented Oct 24, 2015 at 8:49
  • 1
    Maybe it the MAX_FILE_SIZE in php.ini
    – Mohammed
    Commented Oct 24, 2015 at 9:39
  • A disabled "Upload Theme" button? Sounds like one of your installed plugin is interfering with WordPress scripts. Does it work when you upload the theme using FTP?
    – Abhik
    Commented Oct 24, 2015 at 9:53
  • Thank you Abhik, I have tried uploading the theme through FTP, when I navigate to manage themes I get a page not found
    – muya.dev
    Commented Oct 24, 2015 at 10:08
  • Could as well be that you ran out of disk space.
    – kaiser
    Commented Oct 24, 2015 at 10:35

3 Answers 3


I had the same problem, this link explains how to change your filesize upload limit https://www.digitalocean.com/community/tutorials/how-to-change-your-php-settings-on-ubuntu-14-04

Basically find your php.ini file, and change these two below to 30M

post_max_size = 8M upload_max_filesize = 2M


I recommend uninstalling all the other themes from THEMES folder and add the zip file using ftp.

Hope this helped you.


It is often due to the fact that the zip not only contains the theme but also the documentation, readme, photoshop files, , ... You should uncompress the zip file and extract only the zip of the theme. This is the file that has to be uploaded in wordpress.

Not the answer you're looking for? Browse other questions tagged or ask your own question.