1

I set up my site to use SSL and was auditing for insecure content and by process of elimination I found that the plugin serving insecure content is infact Jetpack, and only when connected to Wordpress (it doesn't function without that so that's not much help).

I don't see any options in Jetpack relating directly to either fonts or SSL so I'm not really sure what to look at to get this fixed. I went through the Network tab in Chrome's dev tools and every single resource there is HTTPS.

Jetpack and Wordpress are both up to date (Jetpack 3.7.2 and Wordpress 4.3.1 as of this moment). For now I've disabled Jetpack but I really want it and HTTPS.

0

Well, this was about half my fault half Jetpacks'. Wordpress in general defaults to non protocol-relative URLs (eg http:// not //) and the problem was an explicit http:// image I used Jetpack to insert into my sidebar. Moving that to a protocol-relative // cleared up the mixed content problem.

In general keep an eye out for those kinds of non-relative URLs, I had to redo almost every image URL I had used on the site to get rid of mixed content since Wordpress defaults to leaving those in there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.