What is the best php version to use with WordPress... without going over the top.

  • 2
    – jas
    Oct 19, 2015 at 11:49
  • 1
    the latest one?
    – Sisir
    Oct 19, 2015 at 12:31
  • as all "best" type of question this is so broad it is totally useless. best for what? what is the "top"? Nov 11, 2017 at 21:09

6 Answers 6


There isn't (and shouldn't) be an answer with any specific version for this. New versions come out, old versions get discontinued.

  • At the minimum you should use supported version of PHP. This ensures it still receives bug fixes and (or for less recent version) security updates.

  • Preferably you should be use the latest stable version of PHP. This ensures you get best possible performance.

PHP site has handy Supported Versions page, which clearly covers currently relevant versions and roadmap for their support.

  • This is still theoretical, and not dealing with practical realities. At minimum use the most stable version that supports what you want to do. The version of PHP should not be the tail wagging the dog, as it were. Apr 24, 2017 at 15:08


This has unknowingly came to my attention as it slipped my mind, PHP 5.4 have already reach EOL and the last security support was stopped on the 14th of September 2015.

According to official documentation, PHP 5.5 will finally reach its EOL on the 10 of July 2016 (Active support has already been stopped but this version will still get security updates until its final EOl date of 10 of July 2016).

So to come back to the original question, you should be running on minimum at least PHP 5.5 now, but be sure to get ready to switch to PHP 5.6 within the next 8 months as from date of this answer


Wordpress are still stuck on the dinosaur PHP versions, so any PHP version newer or equal to 5.3 should do.

It is however very very important to note that all PHP versions prior to version 5.4 have been EOL'ed, the last version being 5.3 a year ago. In short, this means than any PHP version older than 5.4 are no longer supported or updated, which will cause huge security issues if you are still using it.

So, for safety, the bare minimum you should be running safely is PHP 5.4.x, where x should be the latest security release.

In short, to be rather safe than sorry, just like Wordpress, it is always always the best to have the latest available stable release installed.

  • How does one "validate a PHP version"
    – Pete
    Oct 19, 2015 at 17:33
  • Check the official docs and my important update Oct 19, 2015 at 17:47
  • It's all a little bit scary now!
    – Pete
    Oct 19, 2015 at 17:49
  • Yes, each major PHP version has a set lifetime (which slipped my mind completely, good you brought this up again). Wordpress has the same policy, but unlike PHP, Wordpress brings out a new major version every 6 months Oct 19, 2015 at 17:52
  • I'm looking for a new host but they don't tell you about the EOL thing
    – Pete
    Oct 19, 2015 at 17:54

To run WordPress we recommend your host supports:

PHP version 5.6 or greater

MySQL version 5.5 or greater

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.2.4+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

For details please follow code link:

Wordpress Requirements


  • Thanks for explanation with using 5.4 as minimum version :)
    – jas
    Oct 19, 2015 at 12:21
  • 1
    Note, this has slipped my mind, PHP 5.4 has already been EOL'ed a month ago. You should be running at least 5.5. See my update to my answer Oct 19, 2015 at 17:47

All the answers here don't take into account an actual, functioning Wordpress environment, but use arguments about end-of-life/support (that is, age). Who cares? What one really wants is stability and functionality. Therefore, one should use the latest version that an entire Wordpress system (with desired themes and plugins) will support. Latest because PHP generally has speed (and stability) improvements in newer versions, but not "the" latest, because stability may suffer.

There are still many plugins (especially those not updated recently) which have deprecated or unsupported PHP code in them, so running the latest and greatest PHP version will not work with those plugins (and themes). 5.6 is the safest, latest version with wide support (90+%), and 7.x is the very latest, and definitely has performance benefits, but a lot of wordpress themes and plugins will not function. Best is to test out your current system and see what your entire environment can work with. Try the PHP Compatibility Checker. It isn't 100% accurate, but gives you something to start with. https://wordpress.org/plugins/php-compatibility-checker/

Finally, PHP versions may have a needed or desired functionality, such as OpCache or php-fpm/mpm-event. In these cases, 5.5 and 5.6 will do.

  • If you want to see what the community in general uses: wptavern.com/php-7-is-now-more-widely-used-than-php-4 Nov 1, 2016 at 5:17
  • there is no way to run secure system on an insecure infrastructure, and there is no way to run stable system on unstable infrastture. By your logic I guess people should still use windows 95 because there is that one program that do not work in windows XP :( Nov 11, 2017 at 21:04
  • @mark-kaplun If you think someone has written something preposterous, best to go back and check your understanding first. "an entire Wordpress system" does not imply ALL Wordpress systems, but rather a fully functional system and its requirements and limitations. In many cases, changing the requirements (for that one program that doesn't support a newer version, say, for example), is a better step to take. Nov 19, 2017 at 4:26
  • no it is not "better" in any way, except for lazinees Nov 19, 2017 at 5:23
  • Would it be better to swap out an old part on a bicycle with a newer part that does the same function, but better, since the old part isn't going to be upgraded by the manufacturer? Or are you just obtuse? Nov 19, 2017 at 17:31

Wordpress now recommends using PHP 7 or above - see https://wordpress.org/about/requirements/

The minimum supported PHP version as of today is 5.2.4.

I would use the latest version of PHP, which is 7.1.


Check the WordPress Requirements for the latest WordPress recommendation. Currently PHP version recommended is 7.2 (or greater).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.