2

I look at the debug.log file a lot while developing, and having all the timestamps in UTC drives me crazy! How can I get them to display in local time? I have my php.ini 'date_timezone' value set to 'America/Los_Angeles' already.

  • Same problem here.. have you figured out how to do this? – neoDev Jan 22 '18 at 8:11
  • Nope. Neither WordPress nor PHP settings seem to have any effect. :( – eljefejb Jan 22 '18 at 16:38
0

What is the time zone setup in your admin -> settings -> general page? WordPress overrides & kind of disregards php's timezone & uses this own settings , if haven't set this - default is UTC+0

Update: according to https://core.trac.wordpress.org/ticket/39595 - wordpress has forced this to be UTC

  • 1
    I have tried both "Los Angeles" and "UTC - 8". Neither seems to have any effect on the error log timestamp. – eljefejb Oct 19 '15 at 15:29
  • same here, changing it seems to have no effect (WordPress 4.9.2) I even restarted the server... – neoDev Jan 22 '18 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.