16

I'm new to wordpress, I set up everything, but there's something that bothers me: on every single URL or link, there's a "?v=hash" appended everywhere (example.com/?v=d21feabed96b).

I tried to see inspect every plugin, I don't understand how this parameter is added.

It looks like it's added in js, because if I see the source, there's no trace of this hash, but I can see in firebug live source.

Plugins installed:

  • jetpack
  • sumome
  • wp-piwik
  • wp super cache
  • woocommerce

Theme: Storefront

I tried to disable everything, but still I get this hash, does anyone knows how and why it's added?

I'm also using cloudflare

closed as off-topic by Mark Kaplun, Nicolai, TheDeadMedic, Howdy_McGee, Pieter Goosen Oct 11 '15 at 8:17

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Just to eliminate the obvious, what theme are you using? – Aravona Oct 8 '15 at 10:36
  • Storefront by woothemes (and woocommerce) – Magnetic_dud Oct 8 '15 at 10:59
  • Thanks for the question. I thought is was something my new server was doing for the DEV copy of my site on a DEV server (using same url, accessed by changing my hosts file). It's been driving me nuts. Thanks to the answers, I now know it's caused by a WooCommerce setting I'd changed on the Dev server (as I change my shopping cart over to WooCommerce from WP EasyCart! Indeed, it's wordpress related after all, but with so many services I use for my website, I had no idea where in the stack it originated. I did not consider it was wordpress (plugin) related at all! ;-) So, Thanks. – SherylHohman Jul 19 '17 at 21:45
30

It was woocommerce, it has a setting "geolocalize users with cache support" which adds this parameter to every single url and link. I noticed that the hash appended was the same in every browser on my computer, so I realized it wasn't a "session" hash, but an IP address hash.

  • 10
    It was at "woocommerce->Settings->General->Default Customer Location", pick the third option, which is IP without cache. – justyy Jun 15 '16 at 22:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.