0

I recently made an existing website into a WordPress multisite, and then added a new site as a subdirectory.

Note: All of this only occurs in the one subsite.

The first problem was that no scripts would load in the admin; no CSS, no JavaScript. I was told to add define( 'CONCATENATE_SCRIPTS', false ); to my wp_config.php, so I did. This enabled the styling but then caused this:

Certain pages (basically anything but the dashboard) will give me a net::ERR_CONNECTION_RESET error. On Chrome, it freezes. In Firefox, it says "the connection was reset." In Safari, it gives me a blank page.

When I take the define( 'CONCATENATE_SCRIPTS', false ); out of the wp-config.php, it loads the pages without the styles, and provides a more specific error: the same one (net::ERR_CONNECTION_RESET) but specifically from wp-admin/load-styles.php and wp-admin/load-scripts.php. I don't have a clue as to why this might be.

On my iPhone, the error given is ERR_INCOMPLETE_CHUNKED_ENCODING, which honestly makes it sound like it's barfing. So yeah.

This problematic subsite has no plugins enabled, and only one theme that has been working perfectly up until this point on another website.

I would provide the URL, but since the issue is 100% backend, I don't think that would be useful.

BEFORE I GET MARKED AS A DUPLICATE:

  1. Yes, I called my host and they both reset the server and upgraded my PHP, neither of which helped.
  2. Yes, I cleared my cache & tried several browsers.
  3. No one else's solution helped, even other answers from this website. I googled the crap out of this. I think it's a unique problem with a similar error.

Any ideas?

3
  • 1
    Based on some initial research, errors like the ones you are reporting seem to stem most frequently from server configuration, data corruption or SSL certificate issues. I've worked in a lot of single and multisite WP instances and I've never run into a situation where setting the 'CONCATENATE_SCRIPTS' flag would make or break my dashboard. Can you elaborate a bit on how you created/converted the multisite instance? How about the server it's running on? HTTP vs HTTPS? Are other sites in the network suffering from the same issues? – dswebsme Oct 3 '15 at 4:30
  • Absolutely. Conversion was done by taking a site that's been online for a year or so, adding the correct code to wp-config, going through the network setup (as subdomains) in dashboard, adding code to wp-config and htaccess, then changing the wp-config subdomains tag to false, then creating my new site. This is what WP Codex dictated. Dash only doesn't work in subsites. It's HTTP. Server is shared hosting w/Network Solutions, I believe it's Linux? Not familiar with servers but can get phpinfo. No other sites are hurt, only subsites of my main site. Thanks for your help. – Brett Goodrich Oct 5 '15 at 1:59
  • Hey @dswebsme, I replied with the information you requested a bit ago; I didn't realize it wouldn't notify you. Here's your notification! Thanks for your time. – Brett Goodrich Oct 11 '15 at 20:24
0

@BrettGoodrich I wish I had better advice for you based on the information you provided but it sounds like you might still be dealing with some underlying server configuration issues, perhaps something that you don't even have control over since it's shared hosting.

When I encounter problems like this I like to try a fresh install of WordPress just to test the server out before I start debugging my own code. If you can put a fresh WP multi-site install on that server and get a sub-site online that will give you a clean testing area.

If you still see the issue on a clean install it's most likely a server issue. If the issue goes away the next thing I'd try is an IMPORT to pull all of your site content into the clean install.

You might also consider reaching out to tech support at your host. I hope this information is helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.