2

I currently have a site running on HTTPS with an SSL plugin activated

Website: https://www.greenwichsentinel.com

SSL Plugin: Really Simple SSL

Wordpress Version: 4.0.7 (Multisite)

Everything seem configured correctly, however when trying to log into the site or view any dashboard panel i get caught in a redirect loop.

For example, trying to log in through https://www.greenwichsentinel.com/wp-admin causes the page to go to https://www.greenwichsentinel.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.greenwichsentinel.com%2Fwp-admin%2F&reauth=1 . The only link that seems to work is https://www.greenwichsentinel.com/wp-login.php .

I have checked every setting and cannot see why this issue occurs. Any guidance on this issue is greatly appreciated.

Thank you

Edit 1 Without the plugin activated and with other plugins this is not an issue, it seems to be tied to this specific plugin

  • Does it happen without said plugin? – Rarst Sep 29 '15 at 18:57
  • Without the plugin there is no issue, and i have also tried other SSL plugins that do not have this issue as well. It seems to be tied to this specific plugin. As a note, the reason i went with Really Simple SSL is because the site load time with other plugins i tested reached well over 10 seconds, whereas this plugin did not have any site slowdown – David Moran Sep 29 '15 at 20:09
  • If it's specific to plugin you will probably have better luck contacting its developers/support about it. – Rarst Sep 29 '15 at 20:12
  • Somehow that did not cross my mind - i will reach out to them and post my findings here, thank you! – David Moran Sep 29 '15 at 20:13
1

you'd be better not using a plugin and editing the .htaccess file (in root of website) something like this at the top:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^somesite.com [NC]
RewriteRule ^(.*)$ https://www.somesite.com/$1 [L,R=301]

so your .htaccess file might look something like this:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^somesite.com [NC]
RewriteRule ^(.*)$ https://www.somesite.com/$1 [L,R=301]

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

and remember to set WordPress Address (URL) and Site Address (URL) in Wordpress admin (settings -> general), so that they are on https not http

0

I used a redirect in .htaccess to a site recently and it seems to be working just fine.

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
0

Unless you're using the Pro edition of the plugin, which includes scans of content in your database, and maybe css and js files, you should put your redirect in the .htaccess file.

Since you're running multi-site, I suggest this:

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

This not only handles your multiple domain names, but ensures a proper 301 redirect to make Google, and other search engines happy, as well as user browsers.

It is also short and sweet, and is done well before loading any PHP code, to help with your initial load speed.

Also be sure you set the site and home path for each site, to use https. This is done as super admin, under My Sites > Network Admin > Sites

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.