1

Since updating to 4.3.1 we are having an issue with permalinks. Our usual practice has been to have a unique article number serve as the postname, and that would be used in the permalink - for instance:

http://our-site.com/1408558

As of the update to 4.3.1, WP automatically appends "-2" to the slug, mimicking behaviour as if a similar post already existed, which it doesn't.

http://our-site.com/1408558-2

While that obviously works fine, it disrupts our normal means of structure and organization for the site.

Here's what I've done so far to investigate:

  • Deactivated all plugins - same behavior exists.
  • Changed to 2015 default theme - same behavior exists
  • Went back to a site running 4.3.0 - didn't encounter this problem
  • Refreshed permalink structure - same behavior exists.
  • Added a non-numeric character in the permalink - problem goes away
  • Changed permalink structure to /testing/%postname%/ - problem goes away

I'd rather not have to add a non-numberic character, and we can't roll back to 4.3 - so I'm really hoping someone else can help me figure out what changed in numeric permalinks going to the most recent version.

  • 1
    possible duplicate of Why can't I save permalink "360" for a page? – birgire Sep 24 '15 at 14:58
  • Hey - thanks for linking to that previous question. We've had no problem with numeric postnames before. The only thing that has seemingly changed has been the recent WP update. – Hal Atkins Sep 24 '15 at 15:07
1

I had the same issue. Couldn't name a page just numbers. Wordpress Version 3.3.1

I solved this issue by using a plugin called "Permalink-editor" version 0.2.12 http://wordpress.org/extend/plugins/permalink-editor/

After that was installed, I am able to clicked "Customize" instead of "edit" permalink on the page edit. That worked! :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.